Alfa Romeo Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
I accidentally caught a wire under the dash on my foot pushing the clutch. It is the orange wire that powers the radio. I found the radio is on fuse 5 so I thought I would find it pulled out of the back of the fuse block. I took a look under there and frankly don’t see where it connects or how to access the back of the fuse block without standing on my head. The view from down at the pedals looking up is hard to tell where to land the wire.

Any tips on how to better access the back of the fuse block?
 

·
Registered
1973 Spider; the daily
Joined
·
59 Posts
I own an s2 spider so I could be different but I find it easiest to unscrew the fuse box, its 2 screws on a s2. Then the end of the wire should have a female blade end. Find a open blade on the number 5 fuse and stick it on. This is easiest done by lying on you back in the footwell looking up until the fuse box is off. Then you can bend the wires to see better. While your down there you might check for any corrosion. If so unplug the batter and clean with steel wool or a metal brush.
 

·
Administrator
Joined
·
16,986 Posts
 

·
Registered
Joined
·
47 Posts
Discussion Starter #4
Fuse box removed. Inspected connections on back and could not find an empty spade connector. Manual indicates fuse 5 is for the radio. I don’t see anywhere this wire has pulled from. I can not locate a radio reference on the electrical schematic I have. Not sure where to land this wire. Any ideas or a schematic that shows an S3 with a radio. I appreciate the help.
 

·
But Mad North-Northwest
Joined
·
10,477 Posts
Radio power on an S3 is a red wire from fuse 5, not orange, at least from Papajam's 88 wiring diagram. I don't see an orange wire to the radio at all.

The only orange wires appear to be for the wiper intermittent device?
 

·
Registered
Joined
·
221 Posts
There is an orange wire which goes to the brake fluid level sensor. It seems to branch off of the wiper connector (behind the glove box), according to the diagram I have......
 

·
Registered
1973 Spider; the daily
Joined
·
59 Posts
Happy easter. Would you mind sending the end of the wire to see the connector. Could have it have possibly pulled out of a connector?
 

·
Registered
Joined
·
47 Posts
Discussion Starter #10
Radio immediately went dead when my foot caught the orange wire. The wire pulled out without a connector, spade or plug.

All other functions seem normal. (Don’t know about brake fluid sensor.

I wonder if this orange wire to the stereo is something the PO did.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #11
Visually inspecting the back of the fuse block I didn’t see a plug or spade that didn’t have a wire attached to it.
 
1 - 11 of 11 Posts
Top