Alfa Romeo Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
440 Posts
Discussion Starter · #1 ·
I need a little help re-attaching cabling and wires to the 1988 Spider I am rebuilding. It was disassembled when I got it, and in fact didn't even have a ECU or associated wiring when I got it.

Using Papajam's wonderful diagram (which gives the colors of various plugs -- a great help), I'm fairly certain I have most of the wiring hooked up in the proper spots.

But when I quit last night, I found I had no idea where the pink wire in my hand goes? It comes from the same harness that has the windshield washer pump wire.

And there is a fitting about the middle of the head that doesn't have an associated plug that I can locate. What goes there, and on which harness can it be found? On this one, the more specific the directions for finding it, the better.

Oh, and one more question: The branch of the ECU harness that hooks to the O2 sensor and continues on toward the driver's side -- by what route should it run? Does it travel under the brake master cylinder and then along the driver's side fender? Or what? Can't find any photos that clearly show that routing.
 

Attachments

·
Registered
Joined
·
502 Posts
Just an assumption: can it be responsible for the fuel pump, just like it was on my Alfetta? It started from a relay cluster on the firewall, at the passenger's side.
 

·
Registered
Joined
·
9,741 Posts
Don't know about the pink wire, sorry.
The switch is maybe the TTS (Thermal time switch)?

Papajam will correct us all:)
 

·
Trained (ex)Professional, , 1953-2018 RIP
Joined
·
16,232 Posts
The sensor on the head is the coolant temp sensor for the ignition computer. The white connector for it is part of the ignition wiring harness so following the harness from the firewall to the coil should reveal the black sheathed wire, (2 wires in 1 sheath) for the temp sensor.

My first thought on the pink wire (is it pink/white perhaps?) was a the same as Q.V. - fuelpump wire. Look for a single wire coming out of the harness (that runs along the firewall) in the area of the washer bottle that has a connector that would fit. This wire may be either pink/white or red/white.

The O2 sensor harness runs along the top of the firewall. When it gets to the left side of the car, it goes down to the O2 sensor. Although I don't recall if it goes over or under the master (can look at our 89 if need be), it does not go along the left inner fender.
 

·
Registered
Joined
·
502 Posts
red/white (or red/black) may be the oil pressure wire, or am I wrong? It's not connected, btw
 

·
Trained (ex)Professional, , 1953-2018 RIP
Joined
·
16,232 Posts
Red/black is oil pressure.
 

·
Registered
Joined
·
440 Posts
Discussion Starter · #7 ·
Thanks, mucho!

I posted the questions, and then did a few minutes of yard work. (There was a "discussion" the other day about balancing the time I spend on the Spider and all the other chores around this little farm we retired to, and one party felt the ratio was skewed badly. I ran the Weed Eater along the edge of the front walkway, which accomplishes a few things. One, it runs on gasoline, which is good -- far better than chores that run on muscle-power. And, two, within a few minutes, there is a very visible improvement. Looks count,)

So, not that many minutes later, I come back in for water and check this bb. Voila, like magic there are answers -- good answers!

So, refreshed and with "chores that show" accomplished, I now head out to the milking parlor (a term I, a city kid, had never heard applied to a barn) and continue sticking the Alfa back together.

Thanks again.
P.S. Carlotta the Spider shares the milking parlor with Walter the Truck, which is right now for sale on eBay. I need the cash to properly finance a paint job. (Look under key-words Ford Truck Other or Woodie if you want to see photos of Walter in front of the barn -- or better, still, if you want to bid on it.)
 

Attachments

1 - 7 of 7 Posts
Top