Alfa Romeo Forums banner

1541 - 1560 of 1874 Posts

·
Registered
Joined
·
487 Posts
My apologies.

Engine has lost the Bosch fuel injection and spark systems along the way. Replacing them are twin Webers, Centerline electric distributor, old school 2 into 1 x 2 cast iron factory exhaust and 10.9 C&B intake cam, stock exhaust cam.
Congrats on the conversion! Is CA the only state in the union that you can't modify your powerplant? It is exasperating! Anyway, much more familiar with the IDE and the IDFs so probably can't be much help.....
 

·
Registered
Joined
·
67 Posts
Cortile della Corsa

Here at the AROC Convention!
My Spider made the 285 mile trip from Annapolis to Pittsburgh in just under 5 hours, including the obligatory gas stop in Breezewood. Ran smooth and normal the whole trip. In this heat, I kept the top up, as well to manage the constant flow of seemingly enormous trucks the whole trip up.

Looking forward to the events over the next two days, beginning with the Gimmick Rally tomorrow morning.

Nice assembly of Alfas from every era emerging in the parking lot already today!
 

Attachments

·
Premium Member
Joined
·
355 Posts
Hit 70k at mile 117 I80 west bound. Wednesday on the way to Pittsburgh.

John IMG_0387.jpg

Sent from my SM-T710 using Tapatalk
 

·
Premium Member
Joined
·
355 Posts

·
Premium Member
Joined
·
848 Posts
Our 1985 "Sandy" spider runs again. Sandy nickname from being submerged in the Atlantic during the storm surge from hurricane Sandy in 2012. 12,xxx original miles, no rust, but previously in the ocean. It has been a long road, not enough anti freeze with resulting cracked block, hip replacement, life in general.

Seems to run good, but takes several seconds to return to idle. Maybe vacuum leak?
Maybe your VSD? Check Skibum's thread,, just sayin',, maybe
 

·
Premium Member
Joined
·
848 Posts
I received my nuts for mounting my DelLorto’s today from Belmetric! I was almost giving in to disgust in my search but Belmetric came through, such a relief.
 

Attachments

·
Registered
Joined
·
487 Posts
Our 1985 "Sandy" spider runs again. Sandy nickname from being submerged in the Atlantic during the storm surge from hurricane Sandy in 2012. 12,xxx original miles, no rust, but previously in the ocean. It has been a long road, not enough anti freeze with resulting cracked block, hip replacement, life in general.

Seems to run good, but takes several seconds to return to idle. Maybe vacuum leak?
Maybe your VSD? Check Skibum's thread,, just sayin',, maybe
He converted to carbs long ago... not a lot of places to get a vacuum leak except for intake manifold gaskets....
 

·
Premium Member
Joined
·
291 Posts
I'm getting rid of the huge flag mirrors on my S4 and mounting Vitaloni Sebrings on the stock mirror bases. Did the basic fitting mods today and tomorrow I'll spray them body color.

I'll do a little tutorial with photos soon.
 

Attachments

·
Premium Member
Joined
·
670 Posts
Got the exhaust sorted out, required some cutting/welding. Not sure why. but ??? Driveline good, cooling system good, and we are out for a cruise. Idles decent around 1k, not real smooth but how smooth can a 4 cylinder be?

Still has the slow return to idle, but not all the time. Tomorrow I will try some carb cleaner/starting spray around the potential intake leaks. Pulled the plugs, black and wet.

Many small items to sort out, but after 5+ years she runs.

Thanks to all for your assistance
 

·
Registered
Joined
·
7,265 Posts
I'm getting rid of the huge flag mirrors on my S4 and mounting Vitaloni Sebrings on the stock mirror bases. Did the basic fitting mods today and tomorrow I'll spray them body color.

I'll do a little tutorial with photos soon.
that is a mod that nobody has done before.

I wonder how the chrome Vitalonis would look there, I had chrome versions on my old sprint....the S4 metal bases can be polished up to a mirror shine to resemble chrome too.
 

·
Premium Member
Joined
·
291 Posts
I'll start a new thread on the Vitaloni Sebrings mirrors so we don't clutter up this one.
 

·
Registered
Joined
·
5,261 Posts
Done! Rebuild tips for driveshaft— use a C clamp to press the caps on the U joints — make sure you put the spring in FIRST!! Use assembly lube on the yokes to get the caps to slide in.

This entire job was done on a bench with no hydraulic press. Use the bearing splitter to grab the old center bearing in front of the rear protective cap, then grab the splitter with a two legged puller, comes right off!!
 

·
Registered
Joined
·
5,261 Posts
Oh yeah photo; new bushing, new u joints, new center bearing and support, clean and grease spline and see how the arrows line up to keep in phase?
 

Attachments

·
Registered
Joined
·
6,808 Posts
1541 - 1560 of 1874 Posts
Top