Alfa Romeo Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
Found a couple things under my hood that I can't figure out. Driver front corner has this little can with a vac line coming off, and no apparent place to attach it. I haven't seen it on other car photos, nor is there anything in my IAP manual. Any ideas? Passenger front corner, a little gadget that should be mounted but is not.
 

Attachments

·
Trained (ex)Professional, , 1953-2018 RIP
Joined
·
16,232 Posts
Can't help with the vac hose but the other thing looks like the air temp sensor for the electric cooling fan (part of the auto cooldown circuit). It should be mounted to the fan shroud which, on your car, is missing.
 

·
1966-2013
Joined
·
13,741 Posts
Ya, little one is the temp sensor for the aux fan as papjam described.

The other, while not having seen one either 'could' be the vac sensor for some type of aftermarket cruise control.

Oh, and your radiator has a pinhole leak somewhere along the top core or hose.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #5
Would that sensor keep the car from starting?
 

·
Registered
Joined
·
416 Posts
...there's a virtual cornicopia (always wanted to use that word)...
Then, you should spell it correctly: cor·nu·co·pi·a:D
 

·
Registered
Joined
·
7,166 Posts

·
1966-2013
Joined
·
13,741 Posts
LOL

Hey, having a large vocabulary has nothing to to with spelling, just the meanings and usages ;)

YOU knew what I ment, even with the typographical error. If I'd have said it verbally, you wouldn't even have caught on :D
 

·
Registered
Joined
·
416 Posts
LOL

YOU knew what I ment...

If I'd have said it verbally, you wouldn't even have caught on :D
Well, I knew what you MEANT :)D), or I would not ahve been able to look up the spelling myself!!
 
1 - 11 of 11 Posts
Top