Alfa Romeo Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
612 Posts
Discussion Starter #1
my friends spider i leaking...
but the only evidence of that, is spark plug socket :/
(picture)

what can be broken?
all hoses are lookin good, without leaks
 

Attachments

·
Registered
Joined
·
143 Posts
Looks like spray from and upper hose is hitting the hood and falling back down on the engine.

If it's Bosch injected, check the hoses that run through the throttle body, which is attached to the plenum.
 

·
Registered
Joined
·
1,195 Posts
I have the same kind of leak, very slow one. I am pretty sure that your leak is from one of the aluminum(?) plugs for the cooling system between spark plugs. I heard that the replacement of the plugs would solve the problem.

It can also be from cylinder head bolts, which is little more serious... Let's hope that the leak is not from there!!
 

·
Registered
Joined
·
612 Posts
Discussion Starter #4
DavidDriver said:
Looks like spray from and upper hose is hitting the hood and falling back down on the engine.

If it's Bosch injected, check the hoses that run through the throttle body, which is attached to the plenum.
thanx guys

nope unfortunetly it is not that
we did check all hoses, and they are look ok.
(unfortunetly - because that will be easy to fix)
and the hood is quite dry :(

tiger`s explanation sounds credible,
so i will suggest to my friend, checking of those plugs:)
do anyone has a picture, drawning, of an engine, without vavle covers, and without head?
 

·
But Mad North-Northwest
Joined
·
9,859 Posts
Hose connections can look fine and still leak intermittently (AMHIK...) Have you gotten the system pressure tested? That's easy to do and should help locate any leaks.
 

·
Registered
Joined
·
49 Posts
I've had a leak from one of the cylinder head nuts cause this symptom. Mine was cured by removing the offending nut, smearing a little silicone sealer on both sides of the washer, and retightening.

Don't do this unless you can verify that the nut is leaking, though, since you do run the risk of compromising the head gasket seal.

The water jacket plugs are an unlikely source of such a leak, since they are almost never disturbed. The nut seating surfaces, though, can suffer from a bit of corrosion, especially if the head has been off a few times.

Bob in Nashville
 

·
Registered
Joined
·
612 Posts
Discussion Starter #11
DavidDriver said:
:p I agree. :eek: It's a basket case.:rolleyes: I'll take it off your hands too...:D
as I said, it is not mine, but mine friends :p

mine has some other problems, though engine in my Alfa is dry and runs perfect...
fried electrical harness - that is PITA ...

Thanks Guys :)
 

·
Registered
Joined
·
612 Posts
Discussion Starter #12
Update:
cylinder head is cracked, between 2nd and 3rd spark plug :/
I dont known if he will fix that, part a car or sell it.
but
stay tuned :)
 

·
Premium Member
Joined
·
26,712 Posts
he3r0 said:
as I said, it is not mine, but mine friends :p

mine has some other problems, though engine in my Alfa is dry and runs perfect...
fried electrical harness - that is PITA ...

Thanks Guys :)
Which harness is fried? I have complete fuel injection harness and plug wires from a 85 Spider.
 

·
Registered
Joined
·
612 Posts
Discussion Starter #14 (Edited)
My is, everything (well, almost) under the dashboard,
mostly around fuse box.
 
1 - 14 of 14 Posts
Top