Alfa Romeo Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
I have been trouble shooting a rough idle and stumbling acceleration on my stock '85. I'm using the excellent online L-Jetronic guide posted here and trying to get through the process methodically. As i was changing some of the vacuum system hoses today, I noticed a slow, steady stream of bubbles coming into the radiator expansion tank as the engine idled. I suspect the bad news is a head gasket leak. Would that explain my symptoms? I retorqued the head bolts to 65ftlbs and that did not help.
 

·
1966-2013
Joined
·
13,741 Posts
Was the engine hot or not when the bubbles occured?

A random tangent would be a faulty rad cap doing the blowby thing.

Any smoke/clouds/puffy fluffy stuff when you're out running with everything up to temperature?

Coolant need frequent topping up?

Off color residue on the plugs? (light gray to tan is the normal sweet spot for L-jet, white crusties on the other hand is not)

Done a compression and/or leakdown check yet?
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #3 · (Edited)
Thanks for the reply. Engine was warming up at idle when I saw the bubbles. Looks like i need to pull plugs and check the compression next...Nothing nasty in the exhaust when it's hot or cold.
 

·
Premium Member
Joined
·
1,520 Posts
;) Were you listening to Lawrence Welk?
 

·
Premium Member
Joined
·
1,520 Posts
Ooops, you are right. Besides, I guess Welks bubbles were falling, not rising.

"No quarter" is my perennial favorite.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top