Alfa Romeo Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Otherwise my low miliage '87 has ran great for the few miles I've put in 2 years of ownership. If I don't tap throttle it dies or nearly before idling down then back up. I've either checked impedence and/or swapped out TTS, CSI, FPR, CTSs', looked for vacum leaks, etc, but haven't gauged fuel pressure. Could be the identical used Fiat parts I tried were also bad and caused the same condition and my lack of electical testing didn't read my meter correctly. It's almost worth living with but I can't, although I'm not the type to replace every suspect componant or even every perfectly good looking hose. I know this is common out there, please save me more time and especially money!
 

·
Administrator
Joined
·
18,681 Posts
Did you check the TPS - Throttle Positon Switch? It tells the computer the throttle is at idle. If it is misadjusted the computer won't know the throttle is at idle. Info on testing/adjusting the TPS is in the L-jet diagnosis page - link below.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Thanks Eric! No, I'll check that. I sure enjoy learning this stuff with help from the forum. I've used that link for reference but didn't pay attention to the TPS adjustment part so I'll try that and report back. Thanks again!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
I can clearly hear the faint click just off the plate closure. Not sure from reading the diagnosis page if checking the resistance values between terminals is still necessary but I will next.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top