Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
811 Posts
Discussion Starter #1
When I got my car out of storage this year the rear drivers side Caliper had leaked all of the fluid on to the floor. I talked to a friend in the local club and I was in luck he had two rebuilt calipers . So I put on the left one then looked at the other one, another left . Oh well I pushed back the piston on the right side and put in new pads. Took the car out and all seemed fine. It stopped rear nice.

Last weekend I lead a group to the Vintage races and half a hour into the trip I could smell hot brakes. Tried adjusting the parking brakes ,that seemed to work. a bit farther down the road more smell and lots of drag. Both side were hot but the right side was much worse.

I figured it was a stuck piston on the right side.I should have taken it apart to inspect it but at the time I did not have the parts to rebuild it.

This brings me to today. I find out I got the wrong rebuild kit, no problem I opened up the second left caliper to take the seals from it. What did I find ? Rust ,Sand and no centre pin. So I removed the rebuilt left I had put on and found no pins in it .

To me the pins and the bits inside the piston look like a return device. I found one diagram on the web but it is the size of a postage stamp and I can not read what it says.

I am going to get my left caliper back rebuild it and put booth the old ones back on. Then I am going to tie a rope to the rebuilt calipers and chuck them in the lake. Hopefully with the guy how rebuilt them at the other end.

Does anyone have any info on how the pistons and the pins work?
 

·
Registered
Joined
·
2,578 Posts
I just did a quick look, but I'm pretty sure there is. I think I also have the hard copy shop manual for the brakes. Will you be there Thursday, or is there a way I can get it to you before then. I'll check what I have when i get home tonight.
 
1 - 4 of 4 Posts
Top