Alfa Romeo Forums banner

101 - 103 of 103 Posts

·
Registered
Joined
·
521 Posts
Discussion Starter #101
Update - Problem Solved!

Hi All - first I want to thank you for all your input. I'd like to report that, at long last, this "running hot" problem has been solved.

The culprit? A re-cored radiator. You heard me right. I had the original radiator re-cored, and it turns out that for whatever reason, it wasn't cooling the coolant enough to keep the temperature within normal limits. We put on a radiator from a GTV6 that did not have any overheating problems (original fans and all), and now no matter how much I push the car on the highway, the temperature stays at 180. Even better, the temperature only rises slightly in stop and go traffic and never comes anywhere near the dreaded third line (100C).

I think still the car would benefit from having the headers ceramic coated (reducing under-hood temperatures is always a good thing), but it's no longer a pressing issue.

Lesson? Make sure any new radiator you put in your car is exactly like the original.
 

·
Premium Member
Joined
·
244 Posts
I am guessing that new GTV6 radiators are no longer available?
 

·
Registered
Joined
·
521 Posts
Discussion Starter #103
I am guessing that new GTV6 radiators are no longer available?
That's a good question. OKP seems to have rebuilt ones (to the original specs) as well as aluminum ones. Alfissimo advertises an OEM one but I havne't been able to get in touch on whether it's actual OEM or reproduction.
 
101 - 103 of 103 Posts
Top