Alfa Romeo Forums banner

21 - 23 of 23 Posts

·
Registered
Joined
·
237 Posts
Old thread....new question.

Old thread. New question.

My tach was frozen. Replaced tach, and threaded new cable/housing through the dash and firewall. What is the proper routing to get to the H2O pump without risking getting tied up in the belts?

Under radiator overflow tank....over the oil filter to the pump connection?
Under the oil filter? Do I tie it down with anything to prevent movement?

THANKS.
 

·
Registered
Joined
·
33 Posts
Last time I did this was to fix a leaking front oil seal. I replaced the water pump at the same time as the pulley is a bit of a mongrel to get off. I left the water pump in situ to remove the tach cable which came off fairly easily after I cleaned off 35+ years worth of caked on grease, oil and dirt.
The tach drive is alloy in my car (Series 2, 1750GTV) and, as shown below, has a paper gasket between it and the water pump housing.
While I had the dash out a few months ago, I also replaced the tach cable.
Chris
Ok, I’ll bite — in the drawing, what in the water pump drives the 101.10.03.103.00 gear that mates with the gear that drives the tach cable...?
 

·
Super Moderator
Joined
·
9,944 Posts
Ok, I’ll bite — in the drawing, what in the water pump drives the 101.10.03.103.00 gear that mates with the gear that drives the tach cable...?
Nothing IN the water pump drives the tach. p/n 101.10.03.103.00 is pressed into the snout of the timing chain step-down sprocket that links the short and long chains, and gives the 2:1 ratio between the crankshaft and camshaft speeds.
 
21 - 23 of 23 Posts
Top