Alfa Romeo Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Hi all.

Thought I'd start a thread on my new project.

I have been a member here for a while since I owned a smoothnose GTJ four years ago, but when my twin daughters arrived it was time to say goodbye.

Then a year ago, I couldn't resist pulling the trigger on a new project car...


(Sorry for the small image)

Historical info from Centro Documentazione Alfa Romeo (FGA) states
“According to our documentation files, the chassis number AR 1293426 originally corresponds to an Alfa Romeo GT 1300 Junior RHD (105.31), manufactured on the 17th October 1970 and sent to Alfa Romeo Australia, Sydney. The body colour is hawthorn white, with black skai interiors.”

After a year of it sitting in storage, I finally got some space at the in-laws and have now begun tear-down.



Got a few panels to replace including the front clip, and have started collecting bits and pieces from ebay and members like Mr Pancho who is luckily local.

Anyway, just thought I'd make a start on here. Been reading loads but I'm sure questions will arise!

Cheers.

Joel
 

·
Registered
Joined
·
34 Posts
Discussion Starter #2
Few more pics of serials and numbers around the car.

If anyone has any more info than the above on model and engine type/age based on these I'd love to hear it.

Seems it's a late stepnose jnr with standing pedals, newer dash etc. Also, it has one of each style of window mech. Anyone know what would have been correct? Id rather replace the cable door as its got more rust but ideally would like for it to be right. Not sure what right is with the alfa parts-bin style the seem to have used.





 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
Discovered some new Hella H4's under these tired plastic covers...


Last reg'd in '91


Engine castings...
 

·
Registered
Joined
·
34 Posts
Discussion Starter #5
Yeah thanks for the reply Andrew, I had forgottent to mention that. Not as nice as having the original 1300 but I'm going to work with what I have I think.

Cheers
 

·
Registered
Joined
·
34 Posts
Discussion Starter #7
So my work so far has been taking the car apart when I'm with it, and bringing things home to refurbish when I'm not.

First up is the gauge cluster.



Seems one is Veglia and one Jaeger.



I'm assuming one has been replaced at some point? Anyone know what is correct for a late (S1?) stepnose Jnr?

The Veglia unit has some seal problems as can be seen. Seems to my untrained eye, that these units are sealed. Anyone had one open?

Also, is there an easy way to check they are working?

Thanks for any info.
 
1 - 9 of 9 Posts
Top