Alfa Romeo Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 · (Edited)
After my long story with changing and timing cambelt here is last issue i have with this car..had parking brake problem but that i fix today so i search forums and couldn't find solution why is car acting like this... Don't know if i can explain
good with my bad english but let try.
When i start to drive straight there is no problem but when i steer to the LEFT >> Right wheel is not making circles it s moving like eclipse up and down..
shaking very bad when i steer to Right no problems... I check steering oil and there is half ... no noise.. i was once before couple months in dealership to check and they told me at is something with strut.. maybe yellow bearing ?


I bought that and wonder if is sure at is that to change tomorrow?
I test car on straight road nothing strange when drive straight but steering left car is unsafe... I hope at don't have to remove steering system .
 

·
Premium Member
Joined
·
6,393 Posts
might be a lot of things

could be the strut/spring is broken, bushings bad, yellow bearing bad, a whole lot of things---
When you had the wheel liner off on that side (pass front on USA car) did you check the front suspension? I think you are going to need to get under the car and figure out what is loose--- I doubt its the yellow bearing alone, check the strut/springs, tie rods, ball joints, etc

after the tbelt work this suspension stuff is easy! Just need a long pry bar and solid car support
 
1 - 2 of 2 Posts
Top