Alfa Romeo Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Does anyone have a Spider 4 (1992) wiring diagram?
I am have some electric problem with the radiator fans as they turn on and stop after 10 secons. Have changed the radiator sensor but no difference, so have to look further into the cabling.
Thks
 

·
Premium Member
Joined
·
3,868 Posts
Does anyone have a Spider 4 (1992) wiring diagram?
I am have some electric problem with the radiator fans as they turn on and stop after 10 secons. Have changed the radiator sensor but no difference, so have to look further into the cabling.
Thks
Welcome to the BB.

You can send a message to papajam. I am sure he has the diagrams.

When you can, we would love to see pictures of your '92.

Good luck,

Vin
 

·
Premium Member
Joined
·
3,868 Posts
Also, from another thread:

There is a thermostatic switch that screws into the radiator on the passenger side of the plastic housing (where the hoses attach). I would warm the car up and see if you have an connection there via ohm meter when car is fully heated up. If no connection after car is past 195 deg, then turn the car off and replace the thermostatic switch. If you do have a connection there, but no fan...then turn the car off and proceed to the fuse box.

Next, check fuse 5. It powers the fan relay (well at least on a 91-94). I would assume same for 90. Check visually and with ohm meter. Replace if necessary. If the fuse is good then check to make sure that the fans have not been disconnected from the factory harness. If good connection for the fans....replace the radiator fan relay. Its the relay in the 2nd position counting along the top row from the left.

Good luck,

Vin
 

·
Registered
Joined
·
9,987 Posts
USA model spider S4 diagram page regarding fans (bear in mind there might be differences to your Euro model S4's, which very likely has no aircon - so no trinary switch, compressor electromagnetic coupling etc - but it should at least help a little!)

you say the fans turn on then go off after 10 seconds?......they would do, if the engine cooled down enough in that 10 seconds........the fans go off once the ignition is turned OFF, no matter how hot the engine is (not a great design, tbh)
The fans only go on when the engine reaches 88C (I think 88 is right), then go off once the engine cools to 85C.

so just wondering here, if your fans are, in fact, not operating correctly??....
 

Attachments

1 - 4 of 4 Posts
Top