Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
I suspect I am not the only one who has had this problem, and can only hope there is a work around or fix avail. The relay under the dash on the drivers side got kicked by a helper driving my 1991 Spider. It broke of course. Now the speedo does not work, and I have been told it also controls the hi/lo headlite beams although since the car is now several hundred miles from me I have not directly confirmed this. The circuit board broke, but MIGHT be fixable by someone that can do careful soldering, maybe but I doubt it. The part # is Sipea 0679, and it is apparently no longer available from Alfa.

A headlite work around might be to switch the hi/lo wires so it is always on lo beam. I have no idea about the speedo. Maybe Palto Alto Speedometer repair has some ideas or work arounds?
 

·
Registered
Joined
·
8,098 Posts
George,
that 0679 sipea relay is only for the interior light delay timer (2 footwell lights and, if fitted, hardtop light)
Sometimes they come up for sale s/h on ebay.
But for now you can just jump it: in effect the delay feature will be gone, but the interior lights go on and off as door is opened/closed.
Eric's useful photo here makes it simple:
http://www.alfabb.com/bb/forums/947119-post2.html

Speedo does not have a relay, but with a bit of luck, might be the fuse that was kicked as well!?
Check fuse #7 (that's 7th from left)......you know it is the fuse if the speedo, the blower fan and the reverse lights all are not working (all on same fuse)
 

·
Premium Member
Joined
·
1,577 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #4 (Edited)
1 - 4 of 4 Posts
Top