Alfa Romeo Forums banner

1 - 20 of 40 Posts
Joined
·
92 Posts
Discussion Starter #1
I leapt into the task of cleaning/lubricating my windshield wiper linkage and have opened a nest of issues which I’m hoping some of you can help resolve.
So:
-on my car, the metal body panel (cowl) that covers the wiper system has a slight angle to it sloping downward from the windshield. It’s not necessarily a big issue, but it’s out of alignment (level) with the adjacent fender panels and looks odd. Is there some kind of rubber strip/grommet that sits between this panel and the body frame underneath that’s missing on my car, or is this just a weird Alfa thing at this location?
-On the Classic Alfa site, there are tapered rubber skirts that fit over the wiper spindles that are absent on my car. They say they are for all Spiders…but I can’t tell if they were ever there. Mine is an ’83…can someone look at a similar vintage and tell me if they exist? Is this clear?
-The black plastic grille that sits on this cowl has lost half of its cylindrical fasteners, so if anyone knows of/has a replacement (grille and/or fasteners - apparently NLA) I would love to talk to you/them.
-And lastly (while I was in the area), I unscrewed the windshield washer pump from the reservoir bottle and now can’t figure out how to hold the filter/nut at the bottom of the bottle to tighten the pump back on; it’s way down there and the filter prevents any kind of socket from fitting on the plastic nut. Any ideas?

This is a great site and I always look forward to seeing all your efforts and hearing your input on mine. Will attempt a tranny oil change within the next couple of weekends and will try some of your suggestions for getting oil back into the case.

Thanks in advance!
 

·
Registered
Joined
·
327 Posts
I've just taken mine off to do some rustproofing and when I put it back on had to make sure it sat on the little metal clips that seem to be part of the screen rubber - otherwise it would have left a gap between the screen and panel - is that what you mean? - mines an S2 but its probably similar
 

·
Registered
Joined
·
184 Posts
-on my car, the metal body panel (cowl) that covers the wiper system has a slight angle to it sloping downward from the windshield. It’s not necessarily a big issue, but it’s out of alignment (level) with the adjacent fender panels and looks odd. Is there some kind of rubber strip/grommet that sits between this panel and the body frame underneath that’s missing on my car, or is this just a weird Alfa thing at this location?
On mine 78. Never the less there was a block of decomposing original black foam about 1/2 wide by 1" tall by undetermined length that rested under the cowl edge to match the fender height. I still have the original sample if you need a reference. But it acted as an unseen perhaps "support" under that cowl edge where the two panels, cowl and fender met. There is still a panel gap between the two areas but if the area under that edge was inconsistent and lower it would level and additionally stop flex if you pushed on that cowl edge near fender.
I replaced with non moisture absorbing foam trimmed to match original, but there may be a sanctioned automotive specific product too.
Shoot a picture (if possible) of the issue perhaps a cowl clip at the windscreen is missing, misaligned or broken?
 

·
Premium Member
Joined
·
857 Posts
The leading edge of the cowl (adjacent to the trailing edge of the bonnet) is secured with screws to the car body - and between these two elements there is a V-shaped rubber seal which is trapped between the cowl and the body, and which extends upward to contact the underside of the bonnet when it is closed. This is about 1/8" thick, so if this is missing, the cowl would slope downward in the manner you described.
As far as the rubber cones over the wiper spindles, I mistakenly ordered these parts, and can say they won't fit an S2.
 

·
Registered
Joined
·
7,295 Posts
FYI - highwood alfa (UK) do those rubber seals at either end of the lower screen chrome trim. (their part # 2270 windscreen trim end gasket) in case they have gone MIA!
And yes, as Brian says, the cowl has to slip between the tongues of the spring clips (takes a bit of doing on your own!) as the top tongue of the clips now left protruding up from the cowl edge, are actully there to secure the lower screen chrome strip along its edge, without them the chrome strip just flops about held on by the 2 end screws.............that is another fiddly job to get right!
 
Joined
·
92 Posts
Discussion Starter #7
You guys RULE! (as my son would say)
I've discovered SO many things wrong in this one small area of the car (including garwood's rubber V strip being mounted backwards and on TOP of the cowl instead of underneath it!), it would take several paragraphs just to describe. :confused: There's a handful of small scale parts and pieces here that PO's and PM's have discarded and/or badly modified over the years, so I will see what I can so to bring it back as close to original as possible.
Thank you all SO much for your input; almost impossible to do without it!
 

·
Premium Member
Joined
·
1,394 Posts
http://www.alfabb.com/bb/forums/spider-1966-up/167970-hood-grill-repair.html

Buzzyotis
Check out the above link to see how I fixed the broken plastic tabs on the inlet cowl.
I have ot reinstalled it yet so no report on durability. I have not figured out how to attach the plastic cowl to the metal yet. Not sure what to use for fastener.

If you solve that let me know.

I agree with opinion regarding PO's.
Seems like you take one area apart to refurbish and find a multitude of sins that have been covered up. Getting the refurbish right is more than half the satisfaction. The other side is kowing ou did it right an it should not refail.

Good luck and take some pictures.
 

·
Registered
Joined
·
171 Posts
'79 Spider Windshield Washer System

I attached a picture from my firewall. I took the water bottle out so you can see the issues I have to deal with. When I press on the washer floor button, the wipers wipe. So that's a good thing. Now I am trying to figure out the electric pump thing.

I am not sure what some of these connections are or how to reassemble this system. There are wires unattached dangling around.

I've got new tubing to run to all the pieces once I get the pump working.
 

Attachments

·
Registered
Joined
·
327 Posts
The back edge of the cover should no rest on those clips. Each clip has three "tongues", two that sit high and one that sits low. The back edge goes beneath the two high ones and atop the low one. If yours is missing those rubber pad, it should still sit properly.
I didn't put that very well but that's what I meant, the trim then clamps between the upper "tongues" and the scuttle panel and is a bit of a fiddle
 
Joined
·
92 Posts
Discussion Starter #12
You guys are awesome!

Thanks for all your replies.
Here's a trivial pursuit cowl question:
I've got all the pieces and parts sorted out but can't figure out what the screws that fasten the cowl to the metal body panel screw into. PO/PM used speed clips on the underside of the frame metal, but this just doesn't seem right; they fall off when you go to undo the screws :confused:. I'm thinking it's something like a plastic drywall picture hanger thingy; conical thing with a flange at one end. I'd like to emulate what was original, but am open to suggestions.

Happy trails!
 

·
Registered
Joined
·
7,295 Posts
on my S4 spider they are little plastic nuts......always splitting open! (I repair them usually with a tiny cable tie:))

I'd just take one of the screws to the local hardware store and get something plastic that fits. (you don't see them they are well hidden under there!)
 

Attachments

Joined
·
92 Posts
Discussion Starter #14
Thanks again

Thanks Dom -
This is what I was thinking went there, although the receiving holes on the body panel are smallish slots, so I will see what the local hadwayha (as they say here in Maine) store has to offer.
Some miscellaneous observations for all posters:
- the rubber fill strips go on either end of the cowl, not along the front edge as I had thought...just figured that one out
- there is a pdf thread here that shows the tapered rubber aprons coming off the spindles during disassembly...so confusing. And it says 'don't mix up the wiper arms'...aren't they identical? :confused:

Thanks for all your support and help!

Craig
 

·
Registered
Joined
·
7,295 Posts
those plastic nuts dont actually fit into the holes in the metal on my S4 (as you say the slots are too small) you just use them like normal nuts from underneath!........in fact anything would work that fits the screw:)
 

·
Registered
Joined
·
22 Posts
Hey guys,

I'm having the same sort of problem - one of the jet washers (PS) was missing so I decided to tackle that problem to see what gives.
Turns out the chrome strip @ bottom of windshield was only heald by the 2 screws at the edges and was glued to the bottom windscreen rubber... (can't be good!)
On top of that it would seem the cowl is kinda riveted to the body in stead of secured with 4 screws... so no way of getting it off without breaking stuff.
I'll post pics later on so you guys can give me an insight in what to do...

Grtz

'87 QV silvergrey
 

·
Registered
Joined
·
22 Posts
As promised the pics.
In one (third if I get my uploads right :)) you'll see the missing washer nozzle..
Any insights are welcome on how to remove these "rivets"
I'd like to replace them with what was originally there in the first place. It'd be nice if someone could point me in the right direction. Pics would even be cooler ;-)
 

Attachments

·
Registered
Joined
·
7,295 Posts
the first 3 photos look like plastic retainers of sorts...put your finger under there to feel what is on the back.....if it is also flat then it is a rivet.....drill them out (the 4th photo is definitely a rivet)

they should be held on with screws and behind the screw is a sort of plastic nut, this is what mine has (anything would work to be honest, that fits the hole!)
http://www.alfabb.com/bb/forums/1183167-post13.html
 

·
Registered
Joined
·
22 Posts
Hey Dom,

I was able to drill out the 4 rivets. The 3 plastic-looking ones were in fact also metal ones, albeit different from the 4th silver one.
Cowl came off after that, area underneath relatively okay. will need 2 new jet washers though :)
But the biggest problem is as I feared: all metal clips to support the cowl/chrome strip are completely rotted away :-(
So how do I go about replacing those ??..

Regards,
 
1 - 20 of 40 Posts
Top