Alfa Romeo Forums banner
1 - 10 of 10 Posts

·
Registered
1991 Alfa Romeo 164 3.0L 184CI
Joined
·
100 Posts
Discussion Starter · #1 · (Edited)
I'm trying to get a dimension for the placement of the Alfa emblem on the rear trunk. If someone could take a measurement from the rear spoiler to the bottom of the circular emblem I would be very very grateful. Thanks much in advance for your help.

>>> 1988 Spider Veloce

I just purchased the car and it was recently repainted just prior to my purchase. This is one of the last parts of the badging that needs to happen
 

·
Registered
Joined
·
139 Posts
I just measured mine. Place it at 1 3/8 inches from the back of the spoiler. Of course you should center it from left to right of the trunk lid.
 

·
Registered
1991 Alfa Romeo 164 3.0L 184CI
Joined
·
100 Posts
Discussion Starter · #3 ·
I just measured mine. Place it at 1 3/8 inches from the back of the spoiler. Of course you should center it from left to right of the trunk lid.
cool! Thank you!
 

·
Registered
1991 Alfa Romeo 164 3.0L 184CI
Joined
·
100 Posts
Discussion Starter · #6 ·
ok... it would have worked out perfect, BUT the adhesive band on the back doesn't doesn't come in contact with the surface of the trunk! Go figure.
 

·
Registered
Joined
·
139 Posts
I would set it with a thin layer of clear silicone..... Spread it thin but leave it high where it does not meet the deck lid. Press it in place then wipe the excess from around the emblem.....don't use too much silicone or you will make a mess. Clean up before it sets up.
 

·
Registered
1991 Alfa Romeo 164 3.0L 184CI
Joined
·
100 Posts
Discussion Starter · #8 ·
yep, actually digging out some clear silicone right now
 

·
Premium Member
Joined
·
1,681 Posts
The trunk emblem on my '88 fits in a round countersunk area, so it's pretty clear where it belongs, but I understand not all years had that round depression in the lid.

When I removed the old trunk emblem last year (because most of the paint was gone), I had to drill 3 holes (just through the metal skin), and then thread some lag bolts with flattened tips into those holes (to force the old badge away from the glue holding it on the trunk). I think I had used a file to flatten the lag bolt tips.

I also had to cut off the two pins extending off the back of the new emblem before I could glue it in place.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top