Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9,410 Posts
Discussion Starter #1
I have a friend's '91 S4 Spider for the weekend and saw that none of the light bulbs for dashboard illumination come on when I turn the driving lights on (but warning lights seem to operate normally). The car supposedly has only 34'000 miles but the interior shows wear more like a 60-100'000 miles car, so I have a hard time believing all light bulbs burnt out at the same time and maybe the instrument cluster was changed (and not correctly connected). I don't know any details about S4 Spiders (but had a quick look at the CarDisc CD and I've seen this thread discussing bulbs but not how to get at them), so I have a few questions:

1. Am I correct that the '91 S4 Spider has no instrument light dimmer (that may malfunction or turn dashboard illumination off)?

2. I understand from the CarDisc CD that the fuse for the instrument lights is the same as some front/rear parking lights and license plate light (all parking/driving lights do come on). Is this correct?

3. Where other than inside the instrument cluster can I check whether the cable that goes to Connector D, pin 6 (illumination) gets power? (i.e. where does that wire go?)

4. Do I have to go through all steps shown on pages 43-3 through 43-8 to get at the light bulbs (or is there a short cut to service the light bulbs)?

5. Am I correct that there is a total of 7 light bulbs for the illumination of the instrument cluster?

6. Is there a way to tell if an instrument cluster has been replaced?

Any help or guidance would be greatly appreciated.
 

·
Registered
Joined
·
9,410 Posts
Discussion Starter #3
Thanks, Tom -- I found the dimmer below the steering wheel on the knee pad (and it was turned to minimum)!
 
1 - 4 of 4 Posts
Top