Alfa Romeo Forums banner
1 - 4 of 4 Posts

Registered
Joined
2 Posts
Discussion Starter · #1 ·
Big question here. Pretty certain I have an OEM Series 2 hardtop, but it鈥檚 just not lining up, fitting tight, and the windows up are not seating correctly. Entire top seems too far forward a bit. Just can鈥檛 get it to seat right. There are only 4 latch points to deal with so it seems like it should sit flush without a ton of effort. Thoughts?
Wheel Tire Vehicle Car Automotive parking light

Car Vehicle Automotive parking light Motor vehicle Automotive lighting

Car Vehicle Window Hood Automotive tire

Tire Wheel Car Vehicle Automotive tire
 

Registered
Joined
1,099 Posts
you need to roll the windows down about an inch or two and then the door should close. I have had one for decades and that's how mine fit Btw, yours looks nice.
 

Registered
Joined
2 Posts
Discussion Starter · #3 ·
you need to roll the windows down about an inch or two and then the door should close. I have had one for decades and that's how mine fit Btw, yours looks nice.
Yes, when I did that I was able to close the doors. Could then roll them up. But would have to roll the windows down every time just to open the door. That doesn't seem too practical. Could it be it was stored on end too long? The fit just isn't right. Feels like it should sit nicely and it's jut awkward. Chance you can get a pic of where your top meets the pilars? I have about a 1/2 in to 3/4 in gap along the side and it begrudgingly fits forward near the pilars.
 

Registered
Joined
1,099 Posts
I don't have the hard top fitted to the car now. I would try getting the "B" pillar fitment first with front latches loose.(screws loosen) You might get a better fit and then tighten front latches and then latch.
 
1 - 4 of 4 Posts
Top