Alfa Romeo Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
Hey Guys,

Haven't posted for a while after numerous help requests from this site (thanks) as I rebuilt my 88 veloce.

Did a bunch of upgrades to my ride (see old posts) and got close to finishing up. Excited to be back in the saddle. Installed the header and silicon hoses, fuel rail rebuilt and blueprinted, head gasket, etc. Fired her up and just can not get it to idle - real rough. We checked and rechecked all the connections as I think it must have a vacuum leak somewhere but to no avail.

So it sits on the jack stands in my (heated) barn. So I thought I would reach out to some of the experienced Alfa tribe for some much needed help :eek:

I am 40 minutes south of Albany NY (Chatham) right next to the Taconic State Parkway - easy access. More than willing to work with and compensate someone to help me get my beloved Italian Mistress purring again. Working conditions are real nice - no laying in the driveway in the snow! Well lit and tool stocked warm shop with the car on stands ready for the final touches.

So if anybody here is interested, or you know a Alfa mechanic that would come to my place, I would be greatly appreciative. Can't stand the thought of missing another season. I really don't think there is anything major to be done, just need a better mechanic to finish it up.

Thanks for any help you can provide.

Dal
 

·
Registered
Joined
·
109 Posts
In the meantime, why don't you take out all the access covers for electrical stuff, get it running, and go around hitting the relays moderately hard with a screwdriver handle, one by one, and listening for any change in engine running?

Can't hurt, solved my problem (little aluminum relay under rear seat '85 Graduate).

Mike
 

·
1966-2013
Joined
·
13,741 Posts
*whips out the shotgun and lets loose a blast*
Was the VVT solinoid set properly and the pin in the cam cover for it installed in the right direction and not sticking?
New o-ring in the idle air bypass?
TPS set properly?
cam index correct?
 

·
Registered
Joined
·
1,725 Posts
Well, I'm in LaGrange just south of you a few miles and could make time to help a fellow sufferer. What kind of adult lube is in the fridge???
 

·
Registered
Joined
·
99 Posts
Discussion Starter #5
Yikes!

Hittin' relays huh? Guess it's worth a shot. Thanks Mike

Darren:
--VVT - I did remove clean and re-install but not sure on how/where to set, pin sticking...think I put it back as it was..
--Yes on the o-ring
--TPS...enlighten me, been a while. I know I should know this but over 50 thing set in.
--My son did the cam thing, rechecked several times and good to go. Also checked compression and good

Gotta tile the bathroom but will try these suggestions asap - not a lot of confidence though :confused:
 

·
Registered
Joined
·
1,725 Posts
The VVT pin can get stuck pushed IN and cause the cam timing to stay advanced giving you a really bad idle that seems like a wicked bad air leak. No adjustment will get it running right. The o-ring is holding it in and could need replacement. Pull the VVT solenoid off and see if you can pull the pin out and then start her up and see if the idle is better.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #7
Halleluya!

Jon,

Just saw your reply. I think you did the posting for the leaking head gasket - my incentive to do mine as the side of the block was oil soaked?

Would love it if you could bring my project to completion - lube, cash, you name it -

Sometimes a fresh set of eyes with (Alfa experience) is all that's needed - the old forest for the trees thing.

Let me know what your schedule (and preference) is and I'll stock up. Weekends are pretty much free for me...

We got some suggestions to start but as you can see by my response might be over my head. Except hitting the relays...bigger hammer..

Will try your suggestion
 

·
Registered
Joined
·
1,725 Posts
I assist for a beer or 2. Cash just gets me in trouble ;-) and my wife will just take it away and buy shoes or something....

See how you make out with the VVT pin. Pull the solenoid, take off the little plate, replace the o-ring and make sure the pin slides in and out easily.

hit me up direct: slocumjon AT gmail.com. Remove spaces and put in the @ sign....
 

·
Registered
Joined
·
99 Posts
Discussion Starter #9
Will do - thanks

I'll try the pin thing and get back to you via g

Back to work now before the boss realizes....

Dal
 

·
Administrator
Joined
·
17,370 Posts
Back to work now before the boss realizes....
Open the Car Talk web page. Scroll down to the bottom for the "BOSS" button. A new page opens with some fake work-like gibberish for your screen. Hit that page's icon if the boss walks by.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #11
:D:D:D
Guys:
Been working 70 hour weeks and will be until June to finish the job I'm on for deadline. Hence, my absence. Anyway, had a little free time this afternoon and decided to fire up Alfie. Started right up and idles decent. Threw chance to the wind and said "enough is enough". Been on blocks w-a-y too long.
Put the wheels on and lowered her down. Drove up to the house and showed the wife. Popping a little and certainly not perfect but has old Stabilized gas in it and has been sitting a long time. Also, an exhaust leak as I shop fabbed the system from the header back. Plan on taking it to a muffler shop for welded pipe from header to muffler when she is back on the road.
Gotta get it inspected and registered for the road. Then I think running it for a while, maybe some seafoam and fresh gas to see what shakes out. Maybe look up Jon and take a ride south for his opinion :rolleyes:
Anyway, wanted to update status as I am pretty pleased especially as things have not been going my way lately. Hopefully, this is a sign of better days ahead!
Granted it needs some fine tuning but I am excited to get it back on the road and see what all the upgrades did for performance. I'm sure I'll be back with more questions as this evolves.
Wanted to thank all you guys once again for the help along the way.

Ciao
 
1 - 11 of 11 Posts
Top