Alfa Romeo Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
247 Posts
Discussion Starter · #1 ·
Good afternoon
I think I might have a gas tank leak in 1974 spider (SPICA to Weber conversion, fuel outlet from bottom of tank), strong smell of gas in the trunk. Seems to localize to the outer border of the gas tank under the gas condensation canister. The edge of the tank-well here is full of rust powder and bits and pieces from over the many years, and these stink of gas when dredged out.I tried plugging all the various tubes running to and from the tank, didn't affect the gas smell. It's not strong around the sender so that seems OK. No gas smell under the car and engine compartment seems OK. Gas smell permeates the ****pit

What should I do next?
If it proves to be the tank, does one have to be criminally insane to embark on welding/soldering repairs (even after steaming the tank for hours, then filling with water and dry ice before starting applying heat?)

Thanks for any thoughts on the matter
 

·
Registered
Joined
·
184 Posts
If it proves to be the tank, does one have to be criminally insane to embark on welding/soldering repairs
Could you do the welding yourself?
Shop in PDX just quoted me $189 for complete repair and resealed sealed vs Brand new for IAP at $239
I am know that in the "Spider Facts" there is multiple post regarding fuel smell from plugged check valves / vacuum relief valves to fabric wrapped lines that disintegrate from the inside out that develop pin holes undetectable from the outside visual inspection.

Some one else may able to be more specific with your stated symptoms.
Good luck
 

·
Registered
Joined
·
247 Posts
Discussion Starter · #3 ·
Thanks for your thoughts Benjamin,

I'm just thinking that if it's a limited hole, then I could either solder or mig weld it my self. Fair bit of cash to have the whole tank reconditioned. Just a bit spooked by some of the cautionary notes you read about welding gas tanks, and wondered if anyone had any direct experience of this.

Perhaps I should try a pressure test to see if I can hear air escaping anywhere before I commit to taking the tank out.

How about tank diagnostics?

Any comments?

Thanks
 

·
Registered
Joined
·
9,977 Posts
A common leak area is where the fuel return line goes into the tank. Either the hose or the fitting.

Gas smell often times comes from the vent system being plugged. Make sure that the metal tube inside the plastic tank is clear.
 

·
Super Moderator
'66 Sprint GT, '67 Duetto, '70 BMW 2800CS
Joined
·
12,490 Posts
Gee, I'd say just pull the tank. It isn't that big a job, and it's going to need to be done one way or the other.

These tanks are formed from two pieces of sheet metal pressed into "bowls", and welded together. In wet climates (does it ever rain there in Seattle?) moisture accumulates in the foam between the tank lip and the body, the metal eventually rusts through, and the tank leaks. From your description, it sounds like this is what has happened.

Once the tank is out, use a hand-powered wire brush to remove the rust. You may see one or more pinholes. If you can't find the leak, put a little gas back into the tank, and rotate it on its side so that the seam is at the low point - I'll bet you'll see gas dribbling out of a pinhole.

You can try having someone weld it, though if the metal is rusted you will probably be throwing good money after bad. You can try that epoxy gas tank repair stuff sold at AutoZone (see picture below) - I have used it in the past, and it seems to work. Or, you could just buy a new tank.

 

·
Registered
Joined
·
247 Posts
Discussion Starter · #6 ·
Well
I did pull the tank. Turns out that the filler area was leaking water that entered round the filler cap and percolated down into the tank bed. The flange was rusted in that area, freely leaking fuel. Also, the return fitting was leaking gas. So I emptied the tank, then steamed it for several hours to distill off the gas. It passed the lighted match test so I tried soldering, miserable failure and the vent tube also fell out as I heated the tank to try to get the solder to take. It didn't take at all, just ran around in balls. Turned to the MIG welder and spent most of the day welding and fill testing with water, welding and fill testing etc. Finally, not too bad, there are a couple of pin holes in the welds but I am sick of chasing tiny leaks so I think I might just seal the welds with the epoxy putty and get the car running again.

Hopefully it will be better if not perfect.

Thanks for your suggestions, you were all right!

The steaming worked a dream, just used a domestic steam cleaner.

Mike
 
1 - 6 of 6 Posts
Top