Alfa Romeo Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
478 Posts
I can see that the oil pressure at idle is around 3, does it go any lower when idling? If so, I suggest not to rev the engine like that if you want it to last much more than 227.000km. Oil pressure in mine is at 2 when fully warmed up.

Anyway, it's a good sign that the sensors works, as that is a weak point on 164's (several threads on this forum about it). The car generally looks good and sounds fine (apart from the noise you asked about?). If service is all right, the price seems fair to me. Any photos of the engine?

What is the instrument light flashing in front of the 'car pictogram' in the dash? I don't recall this one. Also does all the electrics work and do you have the red key and key card? As it has passenger side airbag, it must be 1995 or later and I think these had this keycard systems, but not sure.
 

·
Registered
Joined
·
478 Posts
I looked in my owners manual and it says 'Alarm on' meaning 'The warning lamp flashes when the electrinic theft alarm is activated'.

So as it seems that the siren hasn't started, that has been muted with the small key. It is placed at the right side in the trunk/boot, where the is a "patch" in the carpet and a key hole behind. Since the car can start, this does not seem to be a major issue.

Is there an Owners manual with the car? If not, have a look in the compartment in the rear parcel shelf.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top