Alfa Romeo Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello, 1991 164L has been sitting for 5 years, I have been doing maintenance while working through various issues including replacing ecu and relay with diode. Today's question is: fuel pump powers on when ignition key is turned to on and holds 45 psi but once I hit ignition to fire motor the power to the pump shuts down. I've also replaced the fuel pump rely using a 87 87 not a 87a 87. Could the error be within that rely. My self test shows 4, 4 times so no issues coming from there. Presently we have cutout the power from the rely to the pump and are direct connecting to battery with toggle switch and fuse to pump and it runs great but I'm getting tired of remembering to switch pump off when shutting car down. Thank you for help with this issue happy to have a forum like this to use.
 

·
Premium Member
Joined
·
27,009 Posts
Fuel pump should not turn on with just key on. Fuel pump is only turned on when ECU grounds pin 85 of fuel pump 87 87 relay after engine crank timing sensor sends a signal to ECU indicating that engine is turning over.

Did you use a bosch 0332014112 red stripe relay with diode with 87 87 for ECU and a 87 87 bosch 0332014113 non-diode relay for fuel pump?

Your 164 does not use a 87 87a relay for either red stripe with diode for ECU relay or for fuel pump.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Alfisto Steve Thank you! the fuel pump rely had the a I'll pick one up soon.
 
1 - 3 of 3 Posts
Top