Alfa Romeo Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
347 Posts
Discussion Starter · #1 · (Edited)
Just purchased a PP hardtop with the following problems:

1. Contact cement did not hold on the lower seal, it turns like rubber and rubs off. It looked like the front seal was too thick, so I pulled off the outer one. It left a coating of contact cement that I just pulled off very easily. Also, Both sides were loose and the center. The complete seal would come off very easily.

2. The fastener clips for the front are mounted straight with the top (top front clamps missing - trying to use ones from rag top). Won't work. The rag top has an angle where they mount, would guess @ about 70 degrees.

3. Does the PP utilize rear guides like the Quad, this doesn't have any?

Any Suggestions. Will check it on some of the forums, maybe they can enlighten.

FYI: I have used the "the 3M super trim adhesive" for years. It's not the best I guess, but I couldn't find any better.
 

·
Registered
Joined
·
347 Posts
Discussion Starter · #2 ·
Hardtop

I've solved some of the mysteries of the top myself.

1. Contact cement did not hold on the lower seal, it turns like rubber and rubs off. It looked like the front seal was too thick, so I pulled off the outer one. It left a coating of contact cement that I just pulled off very easily. Also, Both sides were loose and the center. The complete seal would come off very easily.

Changed to the thinner truck/rv tape from the auto parts store and used the "3M Super Trim Adhesive". So far so good.

2. The fastener clips for the front are mounted straight with the top (top front clamps missing - trying to use ones from rag top). Won't work. The rag top has an angle where they mount, would guess @ about 70 degrees.

I think mine were bent upright from usage. Used a vise and small hammer and bent them very slowly, didn't break, and work like a charm.

3. Does the PP utilize rear guides like the Quad, this doesn't have any?

No rear guides, just the side lock downs. Tightened slowly two or three times and looks and seals good. Will check the whole thing for leaks the first time I have it out in the rain. So far, very good, with no air noise. Good fit all around now.

Any Suggestions. Will check it on some of the forums, maybe they can enlighten.

FYI: I have used the "the 3M super trim adhesive" for years. It's not the best I guess, but I couldn't find any better.
 
1 - 2 of 2 Posts
Top