Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
27,389 Posts
Discussion Starter #1 (Edited)
When it rains it pours and did it ever pour good things today.

1. Our RED mini doxie came home from hospital after only two days and $816 bill. She seems to be resting well after a serious intestional and pancreatic attack.

2. My new used Garnet Red Dodge PU is in repaint of hood and fiberglass cap over bed.

3. Installed rear brake valve. brake lines and right rear brake and goodrich SS braided hose on BB2.

4. Harvested nearly new Valeo radiator off Old Blue the Beater and installed BB2's rad in Old Blue. It also nearly new, too but some fin issues.

5. CA gal sent me correct M12x1.25 pitch Perma coil so installed two inserts in rear hub I need for Old Blue.

6. Jon at Alfa Parts Berkeley CA sent me shifter fume seal and special stepped/line hoses for engine oil cooler.

7. My spare flywheel and S clutch arrived from Richard2 arrived. I may have flywheel turned and check clutch on BB2 since I have engine and tranny out.

8. Got a good N41 P/L relay from ebayer in San Diego, too. That will go with me on trip to Alfa convention just in case.

Love it when plans come together.
 

Attachments

·
Registered
Joined
·
8,852 Posts
It's looking like N41 is beyond useful life on the "B"...no dash lights and no tail lights:( I keep threatening to make it a parts car. I already promised my son the radiator.
 

·
Premium Member
Joined
·
27,389 Posts
Discussion Starter #3
N41 woes

It's looking like N41 is beyond useful life on the "B"...no dash lights and no tail lights:( I keep threatening to make it a parts car. I already promised my son the radiator.
I have another N41 spare I can loan you until you part it out if you want it. I try to keep an extra. Recently gave (sold) my friend here one for his 164L.

He gave his old one to an electro wizard in our group to see if it can be fixed.
 

·
Registered
Joined
·
8,852 Posts
Thanks for the offer Steve. I have a good working one in the red car. I need to do some car work today to make sure it's the relay. Now that I think about it, that car has a bad relay socket. That may be the problem, not the relay itself.
 
1 - 4 of 4 Posts
Top