Alfa Romeo Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
In addition to the other minor ongoing problems I now have a major problem. All this week car has been difficult to start, will fire up but will only just about keep revs to 800. After about 3-4minutes car will pick up and run. Now if it starts at all it will just about keep 800 revs but dies as soon as I take foot off throttle. Checked points, plugs and timing all seem ok, any suggestions what to try next, is it possibly a fuel problem?
Thanks again for all past advice and any future advice.
Patrick
 

·
Registered
Joined
·
57 Posts
Discussion Starter #7
Hi All,

I have the car running now, although very lumpy. I reset all timing and points but I think my distributer may be a bit of 'one off' I'm not sure it has all the correct bits, the new condenser doesn't fit with the cap, the cap looks as if it has the wrong check outs, also there seems to be no advance a retard control. The P.O. may have bodged this? Will have to try and look at another dist.

In the meantime whilst running the engine without air filter I noticed that there is a fair bit of fuel coming away from the carbs and into the air filter box. What causes this? How do I fix it?

Thanks again foa ll advice
Patrick
 

·
Premium Member
Joined
·
14,000 Posts
In the meantime whilst running the engine without air filter I noticed that there is a fair bit of fuel coming away from the carbs and into the air filter box. What causes this? How do I fix it?
Fuel pressure too high or float levels too high or leaking needle valves. Pressure should be 3 psi for Webers. Float level depends upon what type of carbs you have.
 

·
Registered
Joined
·
183 Posts
In addition to the other minor ongoing problems I now have a major problem. All this week car has been difficult to start, will fire up but will only just about keep revs to 800. After about 3-4minutes car will pick up and run. Now if it starts at all it will just about keep 800 revs but dies as soon as I take foot off throttle. Checked points, plugs and timing all seem ok, any suggestions what to try next, is it possibly a fuel problem?
Thanks again for all past advice and any future advice.
Patrick
I have a similar problem with my Weber copies and from what I've found, poorly balanced carbs can have the same problems. They get a "reverse pulse" of some kind. I've got the fuel pressure dialed in and the floats are where they should be, but if my carbs aren't balanced correctly I get a fine fuel vapor out of the throat of one of the carbs. As others have noted, a plugged idle jet could put the carbs out of balance and cause this to happen.

It sounds like you did a number of things to the car. Did it ever run well with that distributor and condenser set-up? How many things have been changed since the last time it ran well?
 

·
Registered
Joined
·
57 Posts
Discussion Starter #11
Update on problems.

Hi,
It seems previouse owner was a bigger bodger than I thought! The distributer was the wrong one and was not even working correctly, it was firing all over the place, how the car ran is a mystery. As it is my first Alfa and nothing to compare it to I thought this was maybe normal for a tired 30 year old.
New 123 electronic ignition from Classic Alfa, what a revelation! Car runs lovely and is much quieter and smoother. Car also has new ally carb mounts. I also invested in an air flow meter and balanced and tuned carbs.
Engine is running great now, just back to sorting out all other niggles.

Thanks to all for advice and thanks to Classic Alfa for their help and advice, I can recommend the 123 ignition.
Patrick
 

·
Registered
Joined
·
57 Posts
Discussion Starter #13
Correction & Apology

Last post I recommended Classic Alfa for supplying ignition. it wasn't them it was ALFAHOLICS!!! Not sure why I put classic alfa as I have only ever bought one thing from them in the last 9 months.
So just to make sure it was ALFAHOLICS whosupplied the 123 ignition and many other parts all delivered very quickly and they were extremely helpful to me with all my queries.

Regards

Patrick
 
1 - 13 of 13 Posts
Top