Alfa Romeo Forums banner

481 - 482 of 482 Posts

·
Richard Jemison
Joined
·
7,101 Posts
Discussion Starter #481 (Edited)
Fuel ratio and O2 sensors

Just more FYI:

I pulled the O2 sensor that was in the car at Atlanta, which previously had been in the car for a couple of race seasons, probably overdue for replacement by a couple of race weekends prior to Atlanta. It`s snout was very fowled. I bought a new replacement, but as a test of the "cleaning process" that has common spread in enthusiast media, which is to use a propane torch to heat the probes "snout" until red hot and debris is removed, I did so.

Breaking in the new piston I used a plug in the O2 outlet so that residues of the failure could be burned out of the header system and not further pollute an O2 sensor. After the two 30 minute runs at 2500 RPMs I re-torqued the head to 75 lbft, and installed the old O2 sensor. On restarting the engine the old O2 sensor read correctly, showing a typical 15 reading at idle (best no load idle reading) and fast response to acceleration and higher RPM levels. Those higher levels at "No load" are unimportant and meaningless other than to observe response to throttle openings and the O2`s voltage reaction.

Since it is apparently "working" I`m, going to leave it in and test it at the next "practice" where the engine will be driven at speed, then change to the new o2 sensor to verify readings.

That done I will remove the new sensor and plug the hole and only check AFRs during test/practice sessions, or at events wher ther is a serious altitude difference or weather event...

This engine failure was my fault for messing with a proven setting and ignoring an obvious faulty reading on the O2 meter at idle......:frown2:
 

·
Richard Jemison
Joined
·
7,101 Posts
Discussion Starter #482
Took both the Duetto and the Pinninfarina Coupe to Atlanta this past weekend. Both cars ran extremely well but qualifying the Duetto in Group 3 I had a recurring miss. Turned out after the Saturday feature race with the same miss we found a spark plug with the ground strap fully against the electrode.. ?? How could it have ran smoothly the rest of the time?
Anyway on Sunday`s feature race I started on the pole, and lead the first 4 or 5 laps and lost the lead colling out of turn 7 onto the back strait. Regained the lead in turn 7 and the race was mine to loose, and I did with a wide exit onto the back strait again, and a couple of laps later with a spin at turn 10a on the last lap.

Great race, and the car came home in race ready condition.

The Coupe`s result is in it`s thread, it was it`s test outing and needed some tweeking...
 
481 - 482 of 482 Posts
Top