Alfa Romeo Forums banner

1 - 9 of 9 Posts

·
Premium Member
Spider 2.0 Veloce "Aerodinamica" 1986
Joined
·
80 Posts
Discussion Starter #1
Hello,
My 86 2.0 Veloce had its first service today (well, at least since I purchased it less than a week ago :))
I have noticed that when I start the engine, the warning lights (oil pressure) only comes out slowly. Fading out in 3-4 sec.
Is this a normal behaviour?

(By the way, I know there had been heated debates about viscosity but the mechanic (who has a 82 GTV and a 62 Giulia in his garage) replaced the odd 5W40 with 10W40 which certainly is already an improvement.)
 

·
But Mad North-Northwest
Joined
·
11,618 Posts
Congrats on the new Alfa.

Are you sure you're not looking at the temperature light? On the monopod instrument panel cars ('86 and later) the temperature and brake warning lights should come on at startup and then fade away over a few seconds. The oil pressure light shouldn't be on for any appreciable period of time after starting.
 

·
Premium Member
Spider 2.0 Veloce "Aerodinamica" 1986
Joined
·
80 Posts
Discussion Starter #3
Ah. I'll have to check later today but given the position of the warning lights and my memories from last evening... I presume you're 100% right... Thanks
 

·
Premium Member
1986 Spider Veloce
Joined
·
229 Posts
Here’s an old video of my dash (‘86 Spider Veloce) where you can see all the lights turn on and off.

I think they’re operating normally - so use as a reference?



Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Tchernobyl

·
Premium Member
Spider 2.0 Veloce "Aerodinamica" 1986
Joined
·
80 Posts
Discussion Starter #5
Yes - I'll still double check later today, afterwork but I'm pretty sure it's this light (feeling slightly stupid, there)
Thanks for sharing the vid!
 

·
Registered
74 Spider 78 Spider 84 Spider
Joined
·
786 Posts
My 84 the brake light comes on with the key and then slowly fads away. Very strange. I would think it would stay on bright until I released the parking brake. Or does the brake light only monitor the reservoir?
 

·
But Mad North-Northwest
Joined
·
11,618 Posts
My 84 the brake light comes on with the key and then slowly fads away. Very strange. I would think it would stay on bright until I released the parking brake. Or does the brake light only monitor the reservoir?
The fading away is normal. It's a self-check at startup.

Dunno for sure about the '84 but on my '91 there are separate "Park" and "Brake" lights. The brake light is only for the reservoir. I suspect the 84 is the same.
 

·
Premium Member
1986 Spider Veloce
Joined
·
229 Posts
On my '86 there is a Brake light and a Park light. The brake light goes on with the key and then fades. The Park light stays on until I release the hand brake.
 

·
Registered
74 Spider 78 Spider 84 Spider
Joined
·
786 Posts
I looked up an electronic version of the owners manual. Shows a single warning light for both fluid level and parking brake. I guess the parking brake wiring needs attention since the light is not affected by the handbrake.
 
1 - 9 of 9 Posts
Top