Alfa Romeo Forums banner

1 - 8 of 8 Posts

·
Registered
it's almost a alfa romeo spider
Joined
·
11,002 Posts
Discussion Starter · #1 ·
wel anyway.. i put on new oil seals( crank, front and rear) but there was not to much dripping anyway, but i think my new homemade ovs stoped me from using 1qt per 800/1000 mile to now 1qt every 2000-2500 miles..
 

·
Registered
Joined
·
211 Posts
What does OVS stand for and how do you check it?
My 1990 S3 uses about 1 Qt every 300-500 miles.,
There is no noticeable smoke out the tailpipe, spark plugs are light brown which is good.
I did a compression test with 2 different gauges and came up low in all 4 cylinders @ 100 PSI. It does come up 20 PSI with a squirt of oil.
It does run strong and there is no power loss but recently failed NJ emmisions with slightly high HC 270 @ idle( rec 220 @ idle)
Any ideas ?
 

·
Registered
it's almost a alfa romeo spider
Joined
·
11,002 Posts
Discussion Starter · #5 ·
eyeboy,, been here for a long time..made my own.. thanks
 

·
Registered
Joined
·
1,961 Posts
Hizz what year is your Spider?
Change the Oxygen sensor and the plugs.
Make sure the engine is running at full correct temp if too cold...Bosch Spiders run rich.
(Thermostat, not vlosing).
Elio
 

·
1966-2013
Joined
·
13,741 Posts
If a Motronic 2L is pulling only 100psi on a compression check, I wouldn't classify it as 'runs strong' nor 'not losing power'.
In fact I'd put it as 'lost a lot of power and running very weakly'.

You sure the throttle was WFO when doing the compression tests?

The EFI engines tend to make almost bone white plugs when things are all in order.
Elio gives a good point to start with O2 sensor and plugs.
While the L-jet has an adjustment for idle air mixture, the Motronic does not so it's that much more important that all systems and devices are working properly so the ECU can make proper corrections if you wanna pass any kind of emissions testing.
(90 was an S3 chassis with S4 mechanicals)
 
1 - 8 of 8 Posts
Top