Alfa Romeo Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter · #1 ·
This weekend's project is to revive/restore the horizontal console section, including replacing shifter boot.

Nice soap and water and bristle scrub, along with soak in Back-to-Black and she is looking great.

I was on a roll until I began to tackle the electrics.Thanks to some input on this forum regarding bulb input, the demister button (switch) is working properly.

Yet I'm puzzled by the complete absence of power to the hazard switch per Voltmeter. I tested the switch itself on a separate circuit and the bulb illuminates, so I assume it is working properly.

I thought it may be the parking light fuses so I replaced them. This did not solve the problem. Interesting that the demister has its own fuse yet not the hazard switch.

Turn Signals work fine.

Any thoughts on how to diagnose this hazard switch issue?

Thank you
 

Attachments

·
Premium Member
Joined
·
782 Posts
I found this wiring diagram in another thread, maybe it will help.

Here are some links as well:


Rectangle Font Map Parallel Pattern
 

·
Premium Member
Joined
·
27 Posts
Does your car have AC? There is a number of unrelated differences in the schematics between the non/AC cars. Let me know and I can help from there. The hazard circuit is on non-switched or keyed power so it can be run without the the ignition key. My Monte had a number of gremlins and major voltage drop so I just went through all the dashboard switches. The 10,000 small cuts on my hands are almost healed but it was worth the effort.
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #4 ·
Here is an image of available wires.

May be good to ask what goes where or if you have an image of the underside of demister and hazard that would be lovely
Does your car have AC? There is a number of unrelated differences in the schematics between the non/AC cars. Let me know and I can help from there. The hazard circuit is on non-switched or keyed power so it can be run without the the ignition key. My Monte had a number of gremlins and major voltage drop so I just went through all the dashboard switches. The 10,000 small cuts on my hands are almost healed but it was worth the effort.
Hello - Yes my Monti is equipped with AC . Haha - far from working amd unlikely I’d ever repair , but for wiring guidance - yes AC
 

Attachments

·
Registered
Joined
·
103 Posts
Discussion Starter · #5 ·
I have dove in further and I suspect there are a number of reasons why flasher is not working .

First , I believe the owner swapped the switches.
Please confirm hazard should have seven outer and one inner prongs.

Second, prior owner cut blue and blue/black wires amd hid beneath electrical tape. Bad move .

I will try and reconnect later this week, although my flasher switch won’t stay on down position. There is a new GTV one on EBay for $130 with hazard insignia on its light cover. It has correct number of prongs so hope that will work.

this means that the demister (solid *********** wire) is the one without power. Based upon AC wiring diagram (thanks!!).

So there is one bridged black with two female connectors, one black, one white, one white/black , one blue, one blue/stripe

In meantime enjoy updated image

James
 

Attachments

·
Registered
Joined
·
71 Posts
Hi
My hazard switch is a rectangular one with no light as it's working as a connection of the 2 flasher's circuits plus the light on the dashboard so no need of an extra bulb. There is already enough wiring in the console.
Bernard
Rectangle Font Carton Gadget Shipping box
 

Attachments

·
Registered
Joined
·
103 Posts
Discussion Starter · #8 ·
Thank you for this guideline. I will study it and attempt to apply to my Montreal project.

I do not have a red wire , but will attempt some trial and error to determine proper connections.
 

·
Registered
Joined
·
82 Posts
I don’t remember for the red wire of the button, I think it only serves for the light,
if you dont have one, you can find it on the cigarette lighter
(as I found, sometimes on the Montreal, the + wire is black and not red )
 
1 - 11 of 11 Posts
Top