Alfa Romeo Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1
Im looking for something common with all these fuses but seem to be missing it. I have the wire diagram. Maybe ground but don't see it.
I have checked both sides of each fuse...nada. The others all have power. wipers work, radio, head lights work. Left turn signals work.
10.5 volts to one of the wires in the trunk, everywhere else has 12Volts. But not 7.5 fuses.
Thanks for any thoughts.
 

·
Administrator
Joined
·
16,652 Posts
Are they all on the switched circuits? (but you say the wipers work...). The switched circuits go through the ignition switch. Power goes into the switch (red wire?) and then to the switched circuits in the fuse box (brown wire?). Radios can be wired to switched or unswitched circuits. Headlights are not switched.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #3
I have the key on while testing the fuses. They all have power except the 7.5 amp fuses(6). Is the power coming in on the brown wire then? The plugs on the back of fuse block. Each plug has 2 wires & one goes to one fuse and one wire goes to the fuse next to it. The plugs all seem to be tight/clean. I did take one plug loose to test for power on both wires/none.
thanks for your input.
 

·
Premium Member
Joined
·
1,497 Posts
I have the key on while testing the fuses. They all have power except the 7.5 amp fuses(6). Is the power coming in on the brown wire then? The plugs on the back of fuse block. Each plug has 2 wires & one goes to one fuse and one wire goes to the fuse next to it. The plugs all seem to be tight/clean. I did take one plug loose to test for power on both wires/none.
thanks for your input.
Test for power going to the ignition switch (red wire) and coming out (brown wire, I think). I bet your switch died. But there are multiple terminals on the back so maybe moving the wire will restore power.



Sent from my GM1917 using Tapatalk
 

·
Registered
Joined
·
115 Posts
Discussion Starter #5
Thanks for the help. Ill play around with it some more today. First I have to take my girlfriend ( 11 yrs now) to breakfast. You know Valentines Day. Bah humbug...or something.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #6
I pulled the fuse block down & cleaned a lot of terminals. So, I have head lights, tail lites, left turn, backup lites. No right turn. I have enough to go. So work on others later. (New post)
 
1 - 6 of 6 Posts
Top