Alfa Romeo Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hi, fellows.
My Car is an 164S 1991, does anyone know if there is a fuse or something between the fuel pump relay and the pump.
new relay, new fuse (20) and no power to the pump

PLEASE HELP !!!
 

·
Premium Member
Joined
·
27,526 Posts
The engine has to be turning over or running for computer to energize relay to power the pump. To test fuel pump you can pull fuel pump relay from socket near coil and jumper pin socket 30 pink wire coming from fuse 20 to pin socket 87 pink-white wire going to fuel pump and turn on the key to get pump to run.

91 164 S Won't start | Alfa Romeo Forums (alfabb.com)
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
The engine has to be turning over or running for computer to energize relay to power the pump. To test fuel pump you can pull fuel pump relay from socket near coil and jumper pin socket 30 pink wire coming from fuse 20 to pin socket 87 pink-white wire going to fuel pump and turn on the key to get pump to run.
Thanks, the Pump is working, I jumped directly, and the car
The engine has to be turning over or running for computer to energize relay to power the pump. To test fuel pump you can pull fuel pump relay from socket near coil and jumper pin socket 30 pink wire coming from fuse 20 to pin socket 87 pink-white wire going to fuel pump and turn on the key to get pump to run.

91 164 S Won't start | Alfa Romeo Forums (alfabb.com)
Great advise!!! Is working now!!!
Finally the Relay was the bad part.
Thanks a lot and very best regards!!
 
1 - 3 of 3 Posts
Top