Alfa Romeo Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
Evening all......I'm currently battling this little project -

http://www.alfabb.com/bb/forums/alfa-romeo-cars-sale-wanted/180763-74-gtv-71-1750-spares-project.html

Which is rapidly changing from a "For Sale" thread to a can I finish it prior to moving.......anyway I digress......

I rigged up a electronic pump directly to 12v, where the gas tank used to be in a vain attempt to get her started........anyway, no dice - it'll crank but wont fire. I've cracked the hard lines at the injectors - and it's not getting any fuel, but the fuel is going to the Spica pump - I pulled the fuel line off......

Any ideas - I searched the forum, and the only suggestion I could see was poppets at the bottom of the hard lines (the car has been stood a while).....the two solenoids on the pump aren't getting 12v at any time (Is one the fuel shut off solenoid? And the other is........?)

Prior to me breaking out the manual on CD I'd appreciate a bit of friendly advice :) just want to get her running!

Thanks

Neil

PS I'm only doing this tonight as I got thoroughly bored of welding - managed to grind back the drivers door and weld in new metal to the rear of the roof panel yesterday........
 

·
Premium Member
Joined
·
23,751 Posts
If it's getting fuel into the Spica pump but not out of it, the check valves or fuel cavity must be blocked in some way. Or the hardlines themselves, though that seems unlikely for all four of them.
The fuel cutoff solenoid could be keeping the mixture shut off if it's stuck in the cutoff (extended) position.
Andrew
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #3 ·
If it's getting fuel into the Spica pump but not out of it, the check valves or fuel cavity must be blocked in some way. Or the hardlines themselves, though that seems unlikely for all four of them.
The fuel cutoff solenoid could be keeping the mixture shut off if it's stuck in the cutoff (extended) position.
Andrew
Thanks for the response Andrew - is the fuel cut off solenoid the front one? It's getting fuel into and out of the pump - I pulled the pipe off after the filter housing on the RHS chassis rail..........or is the FC solenoid not in with the filter components (my memory fades......) :confused:

Thanks again

Neil
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #4 ·
I had a read through the cardisc this afternoon, and pulled the FC solenoid off the spare engine......got home (after a mexican meal and a couple of beers) and decided to give the FC solenoid a try.......when I was at it I thought - wonder if the Spica Belt has snapped......checked, and yup - lying around the pulley!

Where do you get them from?.......Had a search on the net at ebspares (was gonna order a few repair panels too) - and nope!

Pointers appreciated!

Neil
 

·
Supporting Vendor
Joined
·
4,464 Posts
Where do you get them from?.......Had a search on the net at ebspares (was gonna order a few repair panels too) - and nope!
We have plenty of Spica belts in stock, as would any of the major USA suppliers. The reason European or UK suppliers don't have Spica belts is there were very few mechanically fuel injected Alfas ever sold there, they were primarily for the American market.
 
1 - 5 of 5 Posts
Top