Alfa Romeo Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Nice forum guys!
I just bought a 77 spider veloce with a peculiar problem; starts easily, cold or warm, runs great for about 30 minutes before a small miss starts and gets progressively worse til it barely runs (about 3-5 min after the first miss).
I'm thinking (hopefully) it's just a fuel filter getting clogged up (ordered a couple-waiting). Any other ideas? By the way, I think this is a CA model cause it's got a smog/air pump.
 

·
Administrator
Joined
·
17,370 Posts
May we assume SPICA fuel injection? That is an important tidbit of info. That, and what color Spider we're dealing with - we need to know all the vital stuff! (and if you had posted some picture like you're supposed to then we'd already know about its color...)

If SPICA, scroll down to the carb/fuel injection section for a couple of 'sticky' threads (always at the top) about the care & feeding of the SPICA system.

For sure filters are important. And fuel supply. How is the fuel pump? When it starts acting up try removing the fuel tank filler cap. Take note if it seems like there is any rush of air going in. Perhaps the tank isn't being properly vented and the fuel pump can't pull against the drop in pressure?
 

·
Registered
Joined
·
797 Posts
Not sure why a fuel filter would get clogged up over 30 minutes and then unclog when you start it again. Sounds more like a SPICA issue...can you verify that the car indeed has SPICA FI or has it been converted to carbs?
 

·
Registered
Joined
·
9,977 Posts
Is the fuel low pressure warning light working normally? Does it come on when the missing starts? When the missing starts, remove the fuel filler cap and see if you get a whoosh of air into the tank, indicating that the fuel vent system is clogged.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Sorry there's no pic yet. If I took one now you'd only see a six-foot pile of snow sorta shaped like a car. If you could see it, it would resemble silver. Very, very faded silver, with maroon interior.

It is indeed spica fi and the fuel lite stays out when running. The tank pump sounds strong with no change in tone. Also there's no whoosh (had that one happen on my dirt bike when the little gas cap hose got clogged.

The reason I thought of the fuel filters is because this exact same thing happened to me years ago on a toyota celica where someone broke off a piece of hose in the tank while trying to syphon gas and the filter would clog from the suction after some time, then after it sat for a little while all the gooey rubber would fall off and run fine again.
 
1 - 5 of 5 Posts
Top