Alfa Romeo Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
361 Posts
Discussion Starter #1
Finally have may drive line problems fixed (clutch pivot, slave cylinder & hose, Giubo, center support and bearing, and 2 new universals) and had a great 6 mile drive (we now have 11 miles together). Looks like I messed up the fuse box moving the pedal box about and the metal bar which holds the fuse box, in it's up position, broke at it's hinges. Tried to epoxy bond a new hinge holder but the bond failed to hold at the fuse box. She's tough to clutch with the fuse box hanging down,
Ran a rubber band from a relay to the fixed bar holder for an emergency fix (dont have a fuse box cover), but band broke...
So would love fix suggestions, it's in the 70's here in Phoenix...It's top down and time to drive!!
Thanks
Paul
89 Graduate
PS What goes in the circular hollow tube in the center of the fuse box, Do?
 

·
Administrator
Joined
·
17,001 Posts
Velcro? Like the kind sold for hanging up a garden hose?

"circular hollow tube"? I'm not sure about your '89 (blade type fuses?) but our '84 (bullet type fuses) has a small light bulb that illuminates when the lights are on and the cover is removed. The light bulb fits into a roundy area in the center of the fuse box.
 

·
Registered
Joined
·
361 Posts
Discussion Starter #3
Thanks Eric..
She's got blade fuses...thinking of a variation on your Velcro suggestion
Have too many megapickels on my camera for a photo
Will get a photo out next week
Thanks
Paul
 
1 - 3 of 3 Posts
Top