Alfa Romeo Forums banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
822 Posts
Discussion Starter #1
Hi,

I wanted to know if someone out there has installed an MSD 6A(L)/Mallory Hyfire 6A(L) or similar in a gtv6 or alfetta. If so, did you have any issues with the tach? Did it still worked?

I have tried the Mallory Hyfire 6AL in my car and the tach is dead and I wanted to know if the tach adapter sold by the manufacturer will indeed correct the problem or I should start searching for a new tach.

Thanks.
 

·
Premium Member
Joined
·
16,151 Posts
The only one I used was a Delta Mk 10B cd unit just to protect the dual point setup on our 78 Alfetta sedan (ran a lower current through the points, reducing arcing and burning of the points). The tach was not affected. I don't think these types of units are otherwise needed in a properly tuned car.
 

·
Premium Member
Joined
·
14,521 Posts
I have an MSD 6AL on my 79 Spider with electronic tach. The tach (and the MSD) work fine.
 

·
Registered
Joined
·
4 Posts
I had an MSB 6Al in my car (84 GTV6) and it need the tach adapter, however I don't remember if it ran without it or if the tach wasn't working. Also I did need the noice filter with the set up. Hope this helps.
 

·
Premium Member
Joined
·
822 Posts
Discussion Starter #5
Thanks for all who replied, I did get the adapter from Mallory and the Veglia Tach now is alive again:D

A fellow alfisti down here in Peru installed an MSD in his Alfasud Ti and he needed the adapter too to triger his Jaeger tach (I think it´s the same brand as the Spider´s:confused:)
 
1 - 5 of 5 Posts
Top