Alfa Romeo Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
8,782 Posts
Discussion Starter #1 (Edited)
I looked at this $500 164L a month ago and passed because of all the electrical and other problems. Mike bought it and now I get to fix it anyway:(
The paint is nice. Only one spot on the trunk the size of a fist where the clear coat is bad. They all seem to have one redeeming quality. It stopped there with this car.

It is really hard to start and doesn't run or idle well at all. Fuel pressure is good and drops faster than I'd like, but it should run. NGK plugs were at .042" so I re gapped them to .025". One wire was disconnected from the Bosch temperature sensor plug, so I put a new one on. I hope that solved the starting issue, but I think the starter is going out as well.

Other issues: Inner and outer door handles broken. I had both and replaced them. The PO put dressing on the tires to make them look good, but the inside of both fronts are worn through 2 layer of cord on the inside edge. The radio was removed with wire cutters. The A/C control panel was flashing like a turn signal and I hear corresponding clicking I traced to the A/C compressor clutch activating like a turn signal. Lower steering wheel shaft cover missing and connectors unplugged. No knob on the shifter (I put one on Mike got from Larry). No right forward wheel well cover. Motor mounts are gone to the point the pan is almost resting on the subframe. The right outer axle boot is totally missing. Mike had a mechanic weld up the exhaust that was coming apart, but it's still noisy. That's as far as I got today. I'll try to start it tomorrow.
 

Attachments

·
Registered
Joined
·
8,782 Posts
Discussion Starter #2 (Edited)
Some more pics...The axle boot is also very close to rubbing on the subframe. I also noticed the small dog bone end is bad. Haven't checked the big end yet.
 

Attachments

·
Premium Member
Joined
·
4,761 Posts
blown strut? ciao, chris these look good in black, dont see many of them
 

·
Registered
Joined
·
8,782 Posts
Discussion Starter #4
Post 2, 2nd pic shows rubber from the motor mount rapped up in the front. The front and rear motor mounts are completely shot as is the front small end dog bone. I haven't checked struts yet, but can guess their condition. This car hasn't seen much love; however, it has a really nice cover between the false fire wall and base of the windshield. One of the nicest I've seen in years. I wonder if Mike will part with it:)
Black and red are my 2 favorite colors for 164.
 

·
Registered
Joined
·
4,049 Posts
Lucky you, right? :001_unsure:

Some normal neglected 164 stuff AND some extras, just for funsies. yikes
:whistling:

It does look like it will clean up well though. :thumbup: For $500, I would have been tempted.
Charles
 

·
Registered
Joined
·
8,782 Posts
Discussion Starter #6
It started much easier this morning, but was missing and I could hear a snap from a bad wire. Traced to #3. I'll replace that this afternoon and go on the next issue....
 

·
Registered
Joined
·
8,782 Posts
Discussion Starter #7
Replaced #3 wire and fired it up...a little rough at first, but the longer it ran the better it sounded. Finally, the white and blue smoke stopped coming from the exhaust, the radiator fan cycled and it idled smooth and took the throttle without issue. I can't test drive this car because Mike has broad form insurance, so only he can drive it.
There's blue smoke coming continuously from the back of the engine and when I was changing the plugs, there was a lot of oil in #1 plug hole. From what I can see of the rear valve cover, it's wet with oil.
The starter stops engaging every few seconds when starting...probably a bad solenoid.
Lots of issues, but this one is on the way to recovery:)
 

·
Premium Member
Joined
·
15,854 Posts
That sucker needs a front end alignment ASAP. Far too much toe out. The tires are dangerous.
 

·
Registered
Joined
·
8,782 Posts
Discussion Starter #10
LOL, no kidding:) He keeps asking if I've taken it for a test drive. I keep telling him no:)
 

·
Premium Member
Joined
·
15,854 Posts
Honestly, I don't know how anyone could drive a car with tires like that. Didn't he even look at them? Sheesh.
 

·
Registered
Joined
·
8,782 Posts
Discussion Starter #12
He hasn't been driving it since he bought it because it was very hard to start. He'll be replacing the tires as one of the items on my list:)
 
1 - 12 of 12 Posts
Top