Alfa Romeo Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter #1
1988 Spider Quadrifoglio

I believe I read on the ABB somewhere that the mounting bracket for the main ECU relay (Bosch) is a ground point. Would someone verify that for me please.
 

·
Registered
Joined
·
9,261 Posts
1988 Spider Quadrifoglio
I believe I read on the ABB somewhere that the mounting bracket for the main ECU relay (Bosch) is a ground point. Would someone verify that for me please.
ground point for what? for the relay itself?
no.
A relay mounting bracket is just that, a bracket to stop it flying around the place. Some relays are plastic and the bracket just slips in, you can use them with or without the bracket

....unless you meant something different?
 

·
Registered
Joined
·
190 Posts
Discussion Starter #3
I meant a ground for the relay as stated on this forum. Didn't think it was but I wanted to verify.
Is there anything special about this relay or could I swap test with one from the fuse box?
 

·
Registered
Joined
·
9,261 Posts
if you mean the "main relay" (as opposed to the big Drive/Fuel felay) then yes, I think one from the fuse box ought to work...horn relay maybe?

What is the relay number presently? what pin numbers?

In fact what is the problem? car not starting? no spark or no fuel?
 

·
Registered
Joined
·
190 Posts
Discussion Starter #5
The main relay # is 0332014125. If you mean the relay spade #'s, I don't have them in front of me right now.
I don't think the cold start system is working and I thought I'd start my diagnosis with the relay and go from there to the CSI and TTS next. Car will start after much cranking when cold and starts fine when warmed up.
 

·
Registered
Joined
·
9,261 Posts
aha
if it is the cold start, that is an independant system.
I doubt a relay has anything to do with it, tbh.

But just for info:
your 03302014125 has these pins: 87, 87, 86, 85,30
any relay with that pin out will work in its place, no need for the bracket for testing purposes.
relay main.jpg

When the car is cold, remove the CSI and have someone crank the starter whilst you aim the csi into a jar......does it spray nicely?
if not, test the TTS this supplies the ground signal to csi
 

Attachments

1 - 7 of 7 Posts
Top