Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
So once again this 86 Spider wants to challenge my nerves. Besides some electrical issues that I continuously work through I never had any engine problems until today.
and I am no mechanic but know enough to get my hands dirty and not afraid to take on a project as long as I know what to do. I did change out my starter twice. That was crazy. But it works fine now.
So a couple weeks back I heard a knocking sound coming from under the car/engine not sure exactly where it was coming from. It seemed to go away when I reved the engine but it kinda knocked a bit when idling. I didn’t give it much thought until today when driving one mile from my home to the tennis court. I seemed to lose power. And I guess compression too.But managed to park it for three hours. When starting back up. It had the sound and compression and power I was used to until half way home. One half mile. Then I had to get up my driveway which is very steep and didn’t think I could make it. But barely. Sounded like if I gave it any more gas it would stall.
So what’s going on here? Any ideas?
I’m thinking it may be my headers have come loose on the exhaust?
Any help or ideas would be very appreciated.
I don’t have any way to lift the car to look under it. I can jack it and look under the engine.
And by the way, I did check and do have oil.
Nothing is leaking.
thanks to all.
 

·
Registered
Joined
·
8,111 Posts
check the big air hose going over the engine. If that has come loose at one end, or has a split, the engine will start and idle ok, but won't accelerate.
The knocking sound is probably something else...are your engine mounts good?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
check the big air hose going over the engine. If that has come loose at one end, or has a split, the engine will start and idle ok, but won't accelerate.
The knocking sound is probably something else...are your engine mounts good?
You were spot on! The big hose was loose and I could pull it off. Tightened it along with some others holding the hose I. Place and Bingo! Thank you!! Love this place.
now only if you could help me finite out why my rear driving light doe not work. All others do. Flasher, stop, reverse. Just one rear driving light out. Replaced the bulb already.
 

·
Registered
Joined
·
246 Posts
now only if you could help me finite out why my rear driving light doe not work. All others do. Flasher, stop, reverse. Just one rear driving light out. Replaced the bulb already.
The contacts on all of the exterior lights become corroded and loose quite quickly. Take each socket out, remove the bulb, clean all contacts, re-flex the positive tabs, apply a little dialelectric grease and you'll keep the police off your back at night.
 
1 - 4 of 4 Posts
Top