Alfa Romeo Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
147 Posts
Discussion Starter #1
Anyone using Innovate LM-2 with RPM signal from Coil?
I'm getting good AFR data. But the RPM signal is not good - working ok at lower RPMs and cruising - then cutting out at high RPMs and then back in intermittently. It would be great to get good clean RPM data!
Has anyone had experience with it?
 

·
Premium Member
Joined
·
14,996 Posts

·
Registered
Joined
·
147 Posts
Discussion Starter #3
Thanks Ed!
I do remember seeing this, and was looking for it this morning, but couldn't find it.
I'm imagining it's a similar issue with the "dirty" signal from the ignition.
I'm not much with electronics. But, I can follow your diagram if I can find the parts. I'll start looking for the parts and give it a try.
 

·
Premium Member
Joined
·
14,996 Posts
I can build you one. I think that I have all of the parts on hand.
PM or email me.
 

·
Premium Member
Joined
·
14,996 Posts
It is fancier than mine as it appears to use active devices. Mine is passive with just 3 wires. I played around with active circuits and never got them to work consistently but in retrospect it may have been due to incorrect grounding. I probably still have one or two lying around but the simple one now works well.
 

·
Registered
Joined
·
147 Posts
Discussion Starter #8 (Edited)
I saw another one as well: Tachometer Signal Filter
But, there is not a lot of information on it from the supplier, and I don't know much about electronics to know myself if it could cause harm to the LM-2 if connected. The fact that it draws on a power supply, rather than being passive, left me unsure about it??

It looks like there are two versions, the one above and an HEI version: HEI Tachometer Signal Filter
 

·
Premium Member
Joined
·
14,996 Posts
My circuit has a zener diode to protect against damaging voltages but I would not recommend connecting anything to the coil of a CD ignition. I wonder how they define "High Energy Ignition"
 

·
Registered
Joined
·
147 Posts
Discussion Starter #10
Hey Ed,
I'm running a 123 Distributor with MSD Blaster 8222 0.7 Ohm Coil with 0.6 Ohm Ballast resistor. This should be ok with your circuit right? I think it's similar to your ignition, but with LM2 instead Zeitronix AFR.
 

·
Premium Member
Joined
·
14,996 Posts
Hey Ed,
I'm running a 123 Distributor with MSD Blaster 8222 0.7 Ohm Coil with 0.6 Ohm Ballast resistor. This should be ok with your circuit right? I think it's similar to your ignition, but with LM2 instead Zeitronix AFR.
Exactly right. Just make sure that you ground it to the engine.
 
1 - 12 of 12 Posts
Top