Alfa Romeo Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,454 Posts
Discussion Starter #1
Hi All,

Started the car as usual last night, drove for 20mins, turned her off, got back after 2 hrs and.... flick.. nothing.

So:

a) I have plenty of charge/battery as indicated by the red charge light in the tacho and as displayed on my subsequent roll start to get me home again.

b) The starter isn't even whirring, which leads me to conclude that either the starter is dead (which I think optimistically isn't the case) or somewhere in the spaghetti from key barrel to starter motor we have a problem.

It was kinda wet tonight, but I've driven her a hundred times before in the wet.

Any ideas?
 

·
Premium Member
Joined
·
21,353 Posts
Sounds like the starter, yes. Have you checked the connections on the battery cables at all ends? Could be ignition switch too. Test by connecting battery + to the ignition switch lug on the starter solenoid. If starter cranks, something's wrong in your ignition switch or wiring.

Andrew
 

·
Registered
Joined
·
141 Posts
Best guess is the starter solenoid. It can be purchased seperately from the starter and is usually the part that fails. To test whether it is the solenoid or the ignition switch, use a remote starter switch. If you hook it up and the starter works, then it is the ignition switch. If nothing happens and the starter doesn't fire, then replace your solenoid (you will have to remove the starter to do this):)
 

·
Registered
Joined
·
1,454 Posts
Discussion Starter #4 (Edited)
Man the starter isnt easy to get to. Ill go get a remote switch tomoro perhaps.

BTW, Fuse 1 (white, 8a) is blown. When I replaced it and tried starting, it blew again. Does that help narrow it down? Sorry, Im really bad at Auto electrics, I hate them with an indescribable passion.
 

·
Registered
Joined
·
1,454 Posts
Discussion Starter #5
Ok.. I have semi-fixed the problem.

I got my hands (very) dirty this arvo and found that the ignition switch lead had wriggled its way off the solenoid connector. Ok, thats fine, reconnect it (why is such an important connection just a simple spade?), put in a new fuse and...

She starts. But my joy is quickly brought back to earth by the smell of blowing fuse. So... I'm happy to carry around fuses til my dying days but obviously theres a bigger problem going on.

To make matters worse, i was using a 25a instead of an 8a fuse because Id run out of 8a, and it still managed to smoke it something chronic.
 

·
Registered
Joined
·
1,454 Posts
Discussion Starter #6
i THINK... I've solved it.

I went back and checked the power wiring and found that when i had reconnected the solenoid wire it may have been in conflict with the batt+ cable terminal and could have been arcing. Obviously after one test start and from peering down between two fat Webers there was little evidence of it, but a re-routing of the solenoid wire and a subsequent test start left the fuse unblown and not smoking.

I'll have to get some 8A fuses though and see if it pops those, just to make sure we dont have any ongoing problems.

Thanks guys for responding.
 

·
Registered
Joined
·
141 Posts
I had the same thing happen to me with my Super. I thought that I needed a new solenoid and it was just that the spade connector had pulled off! Sometimes it pays to take a second and let the anxiety ebb in order to fully evaluate the symptoms:)
 

·
Registered
Joined
·
6,689 Posts
Glad for the happy ending !!
A good measure to do on the old spade connectors is to GENTLY squeeze the end to tighten the connection. This can keep it from falling off again and it makes a better connection.
Randy
 

·
Registered
Joined
·
1,696 Posts
CLearly Pete, the BB was more effective than me with my mobile phone in one hand, while trying to make coffee with another!

Glad to hear its sorted and that its rolling.
 

·
Registered
Joined
·
1,454 Posts
Discussion Starter #12
Ah well I had you and the BB going actually! But thanks Ben, I appreciate your multitasking!
 
1 - 12 of 12 Posts
Top