Alfa Romeo Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Yesterday, my left-hand blinker went into overdrive. Blinking at least twice as fast as it should.

Here's what I know that might be relevant:

All bulbs work.

Every once in a while the turn signal lever hangs up when turning it on for a left hand turn. Actually hasn't been doing it lately.

Had new flasher put in a few weeks ago. Emergencies had been coming on by themselves. Will also put in rebuilt climate control display next week.

Immediately before the problem started, I had a paintless dent removal guy here working on the car (really interesting and effective BTW). While working on the opposite corner (right side), he removed the blinker light module to make a repair. To my knowledge, he didn't take out the left side module.

Any ideas?

Thanks Norm

PS: The car is really coming along. Will post pics when I'm finished. I love the car, but I must admit that I am a bit frightened of the electrical system.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
Well Jason, you nailed it. Thanks.

I hadn't looked closely to notice that the inner of the two back bulbs was out. Removed it and filaments looked fine. Didn't seem to be corroded, but I took a small file to it anyway. Put it back in and bingo, blinker isn't acting like it's on a coffee jag anymore.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top