Alfa Romeo Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1,183 Posts
Discussion Starter · #3 ·
Dick,

I am sorry, I dont always have a chance to check the BB every day. I am located in Pikeville KY which is two hours east and slightly south of Lexington.

Cheers
Martin.

Thanks for the reply.
 

·
Registered
Joined
·
1,183 Posts
Discussion Starter · #5 ·
Dick,

Thanks for the reply. Yes thankfully the car is drivable and it goes into gear perfectly.. so no problems there... its just while it is in gear that it sounds like its "grinding gears" analogous to the sound you make when you "try to put it in gear w/o using the clutch". When I take the car out of gear and leave it in neutral all is well... no unpleasant noises. That is pretty much my best explanation.

This all started about 2.5 weeks ago coming back from a nice jaunt, when decelerating off KY-119 heading home. I down shifted from 3rd to 2nd as I was coming to a stop sign and I heard the noise which progressively got worse the longer I drove the car... luckily I was close to home. I had no trouble driving with the exception of my anxiety level at the development.

Given that the car is drivable, I have been wondering if something has come loose, but my time lately is very limited which is why I have been so long in getting back to you.

Thanks again for your help!

Cheers
Martin.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top