Alfa Romeo Forums banner

1 - 6 of 6 Posts

·
Registered
1973 Spider Veloce 2000
Joined
·
18 Posts
Discussion Starter #1
I finally have my barn find back here in Florida! I'm putting her on jack stands and would love to know if what I'm doing is best.....

For the front stands, I have them under the front members that run parallel with the body of the car, not on the edge where the jack point is...

For the back, I'd like to use the rear axle as my support point, as I'm not sure where else to put them for support....

I'll be taking off the tires, replacing the entire braking system, fuel system, etc....she actually started for me when I put a battery to her and 2 gallons of 93 Octane, but Centerline chastised me for my foolishness...well deserved, though...my passion and excitement to see if she ran outweighed my common sense... ;(

Thanks for your time!

Eddie "pennzo" Gerlach
 

·
Administrator
Joined
·
17,231 Posts
I have them under the front members that run parallel with the body of the car, not on the edge where the jack point is...
Not sure what this means.

For the back, I'd like to use the rear axle as my support point, as I'm not sure where else to put them for support...
Works fine.

Before you get under the car, shake it side to side & front to back. Make sure it is secure!
 

·
Registered
1973 Spider Veloce 2000
Joined
·
18 Posts
Discussion Starter #3
@ghnl,

Thank you!....I'm trying to attach a picture, but it's way too dense to upload...trying to compress the photo so I can share where the front jack stands are at now, but not having much success.....oh, also, Phil at Centerline confirmed the placement of the back jack stands as well.....as long as I have some rags between the axle as to not monkey it up too badly....

BTW, I've got the back tires off...will send photos once I can "make them smaller", as my Android seems to take 5 MB pics... :(
 

·
Registered
Joined
·
642 Posts
@ghnl,

Thank you!....I'm trying to attach a picture, but it's way too dense to upload...trying to compress the photo so I can share where the front jack stands are at now, but not having much success.....oh, also, Phil at Centerline confirmed the placement of the back jack stands as well.....as long as I have some rags between the axle as to not monkey it up too badly....

BTW, I've got the back tires off...will send photos once I can "make them smaller", as my Android seems to take 5 MB pics... :(
You can resize photos on your Android phone:
  • Go to Gallery
  • Select your photo to display
  • Select (at least on my Android phone) Adjustment
  • Select Resize and reduce your photo's size
  • Select Done
Alternatively you can transfer your photos to a Mac/Win computer and do it there.

FWIW I too am annoyed that the BB does not automatically adjust photo sizes on upload. Other BB's do that.
 

·
Registered
1973 Spider Veloce 2000
Joined
·
18 Posts
Discussion Starter #6
Thank you, @BobG! I went to my Gallery Settings and reduced all further photos to 2 MB for the time being..hope the ones above are good to display, but will write these instructions so in the future when I post, the pics will be very clear....

Oh, BTW, I have 4 Chromadora's and 1 Campagnolo....I can now see the subtle differences...if I were to replace, do we go with a different style consistent with the period, or have these professionally refurbished/brightened/chromed? Not sure shiny is the answer, but what I have certainly isn't going to cut it, either!

;)
 

Attachments

1 - 6 of 6 Posts
Top