Alfa Romeo Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter #1
in the engine, It's a constant tick, it does not vary with RPM. Everything in the engine is new, If it moved... it was replaced.
Any clues on what to look for before I tear into this thing?:confused:
 

·
1966-2013
Joined
·
13,741 Posts
'Does not vary with RPM'

That's a tough one.

Here's a goofy thing to try: Take the lighter out of it's socket, set the heater controls to dead center, make sure all the ducts/vents are wide open, tape your keys together (or just use an ignition key by itself with no ring) and empty the glovebox and trunk, then see if it still does it.

I had one that was bugging the crap out of me for weeks that I couldn't locate til my wife was with me one day and I asked if she heard it. She just looked over and said 'you mean the keys clinking together?'.....
 

·
Registered
Joined
·
3,927 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter #4
I'm starting to think its something along those lines that something is just banging away( guess thats todays project.)
I did have the sqme problem with my keys, except they would swing up and hit the positive terminal on my aftermarket voltmeter, blowing the fuse. 8 fuses later, I finally figured it out, and moved the gauge.
 

·
Registered
Joined
·
142 Posts
Discussion Starter #6
clock hasn't worked since day one, I do have a mech. stethoscope, I just can't remember who borrowed it...( time to make some calls)
 
1 - 7 of 7 Posts
Top