Alfa Romeo Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
467 Posts
Discussion Starter #1
I've never thought much of this, but the air intake pipe(?) doesn't align with the other pipe, that it appears to be meant to align with in my '78 Spider, in fact there's quite a gap. I've attached some pictures, hopefully it is clear what I'm talking about, because my vocabulary doesn't seem to be sufficient enough to describe these things. Are these meant to be aligned? Is there some way to align these pieces? It all seems to be pretty rigid. Am I loosing out on anything by having these out of line?

Thanks for your thoughts.
 

Attachments

·
Registered
it's almost a alfa romeo spider
Joined
·
10,928 Posts
it's ok.. but if you want to make it better, go to ace hardware get some of that dryer exhaust tubing. and slip some over and fill the gap'' might make you car faster..( just a wee bit)...... just noticed.. is that a ' White ' spider? hummm..:):) we all know about those ' white' spiders here.. i hope it works out for you, the gap is nomal.. have fun with your spider.
 

·
Registered
Joined
·
2,169 Posts
There was originally a black plastic hose that went from the fitting you show there to the SPICA air cleaner. You have carbs, I'm guessing?

-Jason
 

·
Premium Member
Joined
·
1,699 Posts
The black plastic hose was only used 1971- 1974 on the Spica cars. 75-79 look exactly like the picture. Normal for a 78. I don't think a piece of dryer hose will make any difference at anywhere near legal speeds. And something else to flop around in the engine compartment.
 

·
Registered
Joined
·
2,169 Posts
The black plastic hose was only used 1971- 1974 on the Spica cars. 75-79 look exactly like the picture. Normal for a 78. I don't think a piece of dryer hose will make any difference at anywhere near legal speeds. And something else to flop around in the engine compartment.
Ah, gotcha. Never owned a smog-era SPICA car, so that's a new one on me.
 

·
Registered
Joined
·
797 Posts
I replaced my air filter with one from a 71-74. This allowed the use of the hose to connect the two and I just thought the whole setup looked cleaner (better). The previous owner removed the smog equipment and had crushed the pipe that connected to the warm air hose, I guess to try to block it off.
 
1 - 7 of 7 Posts
Top