Alfa Romeo Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
Why does my Jaeger oil pressure gauge moves the wrong way?
At idle its at 8 and by revving it goes down.
It seems to be working nicely but just does the job in the wrong direction....the red warning light is working.
The previous owner has replaced the sensor, as that was looking cleaner then rest of the engine. Its a 2000 in a 71 GTJ1300. I can see that new rpm meter has been bought recently in documentation.
Looking at the similar threads, it should not work at all if its wrong type sensor?
 

·
Registered
Joined
·
922 Posts
if wrong type of sensor is used it works exactly the opposite way, so search for the correct sender for your Jaeger gauge and you will be fine
 

·
Registered
Joined
·
237 Posts
Why does my Jaeger oil pressure gauge moves the wrong way?
At idle its at 8 and by revving it goes down.
It seems to be working nicely but just does the job in the wrong direction....the red warning light is working.
The previous owner has replaced the sensor, as that was looking cleaner then rest of the engine. Its a 2000 in a 71 GTJ1300. I can see that new rpm meter has been bought recently in documentation.
Looking at the similar threads, it should not work at all if its wrong type sensor?
Yes Quadrifoglio is right. You have to use the correct type for the correct gauge/dial/instrument maker i.e. one specific sensor type sensor for the Veglia Borletti & one specific sensor for the for the Jaeger dials

In cas you need one for the jaeger instruments just let me know, I have a brand-new spare one @ home, that I just purchased but that I do not need.

Kind regards

Thomas
 
1 - 3 of 3 Posts
Top