Alfa Romeo Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
218 Posts
Discussion Starter #1
Fog lights work fine, Turn signals work fine, Heater fan works fine.....
That being said, the indicator lights on the cluster work when they want to....just like most other electrical problems, I believe it is a ground...does anyone know where there is a common ground for these in an '88??
 

·
Administrator
Joined
·
16,624 Posts
Well, in our '84 Spider the gauges have a black wire for grounding. (Our Spider has the dual pod speedo/tach & 3 gauges at the top of the console). There are a couple of ground points I recall from when I removed the dash.

1) There is a ground way up under the dash near the front center. I added a ground wire from that point to the body ('chassis') so that the ground path was not dependant on the dash mounting bolts.

B) There is a grouped grounding point at the left, lower, rear corner of the dash. Open the door and look up where the bottom of the dash is closest to the door opening.

HTH
 

·
Registered
Joined
·
55 Posts
I had several issues with the indicator lights on my '87 Quad. Found the ground wires attached to body just in front (on left and right) of the radiator top. Screw was rusted and once removed, cleaned and replaced all was fine.

Windchill
1987 Quad (silver)
 

·
Trained (ex)Professional, , 1953-2018 RIP,
Joined
·
16,232 Posts
According to the wiring diagrams, the cluster instrument lights ground wire is on cluster connector D4 and grounds to the body at connector G54B located in the rear of the passenger compartment.
By indicator lights do you mean the turn signals? If so, power comes into the indicator light thru cluster connector D2.

If you'd like a diagram of the cluster wiring, please send me a PM with your email address.
 
1 - 5 of 5 Posts
Top