Alfa Romeo Forums banner

1 - 9 of 9 Posts

·
Premium Member
1984 GTV6, 1973 Berlina, 1987 Milano
Joined
·
1,592 Posts
Discussion Starter #1 (Edited)
Does anybody have any tricks for reinstalling the passenger or right side timing belt cover?

Also, has anybody who's running the new Staybelt timing belt tensioner had any interference issues with the tensioner and cover?

I just finished up a major resealing on my 84 GTV6 - new cam seals and o-rings, crankshaft seal, cam cover gaskets, spark plug gaskets, new plugs, hoses and belts!

But apparently I should have put the timing belt cover back on before installing the hoses and filling it back up.

One friend suggested removing the sensor on the right side of the thermostat housing. I might try that. Or drain the coolant and remove the heater hose and upper radiator hose as well as that sensor. But I'm hoping there's a trick I'm missing.

I did get it on somehow, but I couldn't get the bottom bolt started. The cover seemed to be hanging up on something and wouldn't sit flush, hence my question about interference with the tensioner.

I have been working on it for 2 weeks an hour or two at a time and I'd love to be done with this project!

Thanks,
Ian
 

·
Premium Member
Joined
·
746 Posts
It sounds like you are talking about the cam belt cover, not so much the cam cover. I found I could squish the rad hose and heater hose out of the way enough. Having the two belts off helped me. For the bottom bolt, are all the other bolts out or loosened off lots? Sometimes I find if I have trouble lining one up that I need to go back and make that the first one I do. It also seems like every bolt for that cover is a different length.
I don't have a Staybelt, sorry.

Cheers,
 

·
Premium Member
1984 GTV6, 1973 Berlina, 1987 Milano
Joined
·
1,592 Posts
Discussion Starter #3
You're right, I meant timing belt covers. I edited the original post.

I did what you said the first time, just tried to squish the hoses out of the way. But it definitely wasn't easy.

I also tried putting the top bolt in very loosely to have a reference point. As well as starting with the bottom bolt. I guess I will just keep trying!
 

·
Premium Member
Joined
·
1,229 Posts
Will be interested to see how this story ends as I am planning to do a Staybelt next belt change.
 

·
Premium Member
Joined
·
14,241 Posts
I don't think that the staybelt tensioner makes it any more difficult to install the belt covers
 

·
Premium Member
Joined
·
1,650 Posts
I have installed a few of the the old Tom Zat tensioners and 1 of the new Centerline Staybelt tensioners and no issues, Cover clears just fine.
 

·
Premium Member
Joined
·
1,229 Posts
Ah that’s right...I forgot this is based on the old Zat tensioner. Good to know...that has a long track record.
 

·
Premium Member
1984 GTV6, 1973 Berlina, 1987 Milano
Joined
·
1,592 Posts
Discussion Starter #8
So I attacked the covers again after a break and got it back on.

I used my spare engine to help located the threaded boss. (who knew having a spare engine under the workbench would be so handy! Lol) And here are a few photos in case anybody else needs help.

Looking at the bosses on the back of the cover I was able to figure out how to work it past the pulleys. I definitely had to bend and shove it a few times, and at some point it won't like that. But for now it's back on.

I started with the bottom bolt, then the middle bolt, and finally the top bolt that also holds the bracket for a fuel line.

Next up, cleaning the engine.


 

·
Premium Member
Joined
·
1,229 Posts
I used my spare engine to help located the threaded boss. (who knew having a spare engine under the workbench would be so handy!
Not sure if it applies for you here, but it was when doing this job on my GTV6 I learned the trick of shoving my phone into dark, unseeable places in the engine bay to take shots of things I couldn't otherwise see. You probably know that trick, but your comment just made me remember that moment from doing this job a few years back.
 
1 - 9 of 9 Posts
Top