Alfa Romeo Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
Ok so I found another Idle Air Control Valve on ebay for $39, put it in a couple days ago, problem solved, idle is steady. However I think it would be even smoother if the part would have come with a new ruber gasket that goes on the spout that goes into the intake, the old one is pretty ratty, im surprised it works. Anybody know where to find that part or what they call it? Ive tried looking for Gasket, rubber gasket, Idle vale Gasket etc. Anybody ?

Thanks for your time, my best to you and yours and may the rain never catch you with your top down.....

Regards,
Terry
91 Spider 25K original miles
 

·
Registered
Joined
·
7,305 Posts
can't get that part anymore (called an Idle valve rubber seal/grommet), but putting it in with a little sealant or silicone grease helps seal.....you do not want any air leak there!

you could try diFatta with the part number 60513192 maybe, case they have old stock floating around?

these were the last 3 I saw for sale in France, now sold.
 

Attachments

·
Registered
Joined
·
78 Posts
Discussion Starter #3
IACV Gasket

can't get that part anymore (called an Idle valve rubber seal/grommet), but putting it in with a little sealant or silicone grease helps seal.....you do not want any air leak there!

you could try diFatta with the part number 60513192 maybe, case they have old stock floating around?

these were the last 3 I saw for sale in France, now sold.
Thanks for the info. Like I said mine is very shabby, I need to do something.
Also I think I may have been better off spending the money for BOSCH, my car is already starting to act up again on occasion.
 

·
Registered
Joined
·
7,305 Posts
the 91-93 year 164 alfas used the same seal, although a different IAV (might find one at a breakers yard?)

if you are really stuck, there is one on german ebay (though I realise it is a long way from here to MD!)........he says for the alfa 75 (Milano you call it, I think?)

ebay #: 161223388662
 

·
Registered
Joined
·
115 Posts
Hello Terry,
Please see my current post on my 91 Spider not holding idle. I wonder if I have the same problem you had? It won't hold idle, just cuts and stalls. Something is causing the engine, after start, to just lose power, cut out, and stall. My IAV rubber grommett fits ok but it does not appear to have a tight seal into the plenum.
 

·
Registered
Joined
·
133 Posts
the 91-93 year 164 alfas used the same seal, although a different IAV (might find one at a breakers yard?)

if you are really stuck, there is one on german ebay (though I realise it is a long way from here to MD!)........he says for the alfa 75 (Milano you call it, I think?)

ebay #: 161223388662
Does the IAV go by another name possibly. Looking at the air intake circuit in the 91' spider manual I don't see that item. There's an Idle speed actuator ... is that it?
Jim
 

·
Registered
Joined
·
115 Posts
Yes Jim, the IAV is the idle speed actuator. The naming gets botched sometimes by some folks. It's the cylindrical unit that controls the idle of the engine.
Vince
 
1 - 7 of 7 Posts
Top