Alfa Romeo Forums banner
21 - 34 of 34 Posts

·
Registered
Joined
·
521 Posts
Tip: You can open the image on your computer and use the Windows 'snip' tool to copy and paste it right into this box or an email or anywhere else you prefer.

 

·
Registered
Joined
·
16 Posts
Discussion Starter · #25 ·
OK pics maybe better? The testing I have done says yes but let me know!
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #26 ·
#1, drain the fuel tank! Do not pump that old nasty, up through the injectors. Me, I would pull the fuel tank and open it, flush it, inspect the in-tank pump and filter sock, replace the in-tank step hose and all the external fuel hoses (8mm and 12 mm ID), and the main fuel filter. Then confirm the operation of both fuel pumps. 100k miles and no service records, I would remove the valve cover and service the valve lash and timing chain tension. Suction the oil from the cam journals and refill with Valvoline VR1 20W-50 and a new filter. Drain coolant and refill with water. Once engine starts, repeat until water runs clear. Then refill with proper dilution of antifreeze. Good luck!

100% Yes I agree. I am selling a truck this weekend, once that capital is in hand I will be shopping for the Alfa.
 

·
Premium Member
Joined
·
2,203 Posts

·
Premium Member
Joined
·
785 Posts
This looks like a lotta of fun... I always thought blue was a good color on this car. Good luck!
 

·
Registered
Joined
·
143 Posts
Has anyone else mentioned the aftermarket headers?
 

·
Registered
Joined
·
11 Posts
I bought an 86 a few years ago, similar but just a bit worse shape. Another year or so and she will be good as new. Do a little bit of Alfa every week and stay motivate, you will be driving her in no time at all.
 
21 - 34 of 34 Posts
Top